summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-05 00:25:39 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-09-05 00:25:39 -0400
commitc7777a81a7fe3dddf312caad6e97451b81fcc71a (patch)
tree809c1e4eb3ef619a364f4bea51e108db255c4285
parentmate-extra/caja-extensions: Version bump to 1.14.0 (diff)
downloadgentoo-mate-c7777a81a7fe3dddf312caad6e97451b81fcc71a.tar.gz
gentoo-mate-c7777a81a7fe3dddf312caad6e97451b81fcc71a.tar.bz2
gentoo-mate-c7777a81a7fe3dddf312caad6e97451b81fcc71a.zip
app-arch/engrampa: Update p7zip support
Package-Manager: portage-2.3.0
-rw-r--r--app-arch/engrampa/engrampa-1.10.2-r1.ebuild (renamed from app-arch/engrampa/engrampa-1.10.2.ebuild)5
-rw-r--r--app-arch/engrampa/engrampa-1.12.0-r1.ebuild (renamed from app-arch/engrampa/engrampa-1.12.0.ebuild)5
-rw-r--r--app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.09-compat.patch25
-rw-r--r--app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.14-compat.patch30
4 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/engrampa/engrampa-1.10.2.ebuild b/app-arch/engrampa/engrampa-1.10.2-r1.ebuild
index f0fc91b..8a613bc 100644
--- a/app-arch/engrampa/engrampa-1.10.2.ebuild
+++ b/app-arch/engrampa/engrampa-1.10.2-r1.ebuild
@@ -38,6 +38,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.10.2-p7zip-15.09-compat.patch"
+ "${FILESDIR}/${PN}-1.10.2-p7zip-15.14-compat.patch"
+)
+
src_prepare() {
gnome2_src_prepare
diff --git a/app-arch/engrampa/engrampa-1.12.0.ebuild b/app-arch/engrampa/engrampa-1.12.0-r1.ebuild
index c1ec897..48c44f3 100644
--- a/app-arch/engrampa/engrampa-1.12.0.ebuild
+++ b/app-arch/engrampa/engrampa-1.12.0-r1.ebuild
@@ -37,6 +37,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.10.2-p7zip-15.09-compat.patch"
+ "${FILESDIR}/${PN}-1.10.2-p7zip-15.14-compat.patch"
+)
+
src_configure() {
mate_src_configure \
--disable-run-in-place \
diff --git a/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.09-compat.patch b/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.09-compat.patch
new file mode 100644
index 0000000..d0937a8
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.09-compat.patch
@@ -0,0 +1,25 @@
+From 4f65bde8fc4d4efe747d4e7fbeba1211469ed79a Mon Sep 17 00:00:00 2001
+From: monsta <monsta@inbox.ru>
+Date: Thu, 24 Dec 2015 17:11:19 +0300
+Subject: [PATCH] 7z: correct checking for p7zip 15.09+
+
+from https://github.com/GNOME/file-roller/commit/ed9c3fd2
+
+fixes https://github.com/mate-desktop/engrampa/issues/114
+---
+ src/fr-command-7z.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/fr-command-7z.c b/src/fr-command-7z.c
+index 297ba1b..0b784f7 100644
+--- a/src/fr-command-7z.c
++++ b/src/fr-command-7z.c
+@@ -106,7 +106,7 @@ list__process_line (char *line,
+ strncpy (version, ver_start, ver_len);
+ version[ver_len] = 0;
+
+- if (strcmp (version, "4.55") < 0)
++ if ((strcmp (version, "4.55") < 0) && (ver_len > 1) && (version[1] == '.'))
+ p7z_comm->old_style = TRUE;
+ else
+ p7z_comm->old_style = FALSE;
diff --git a/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.14-compat.patch b/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.14-compat.patch
new file mode 100644
index 0000000..4e25898
--- /dev/null
+++ b/app-arch/engrampa/files/engrampa-1.10.2-p7zip-15.14-compat.patch
@@ -0,0 +1,30 @@
+From a2a537eb4c263a5b33851572a189fe89476b212e Mon Sep 17 00:00:00 2001
+From: sc0w <scow@riseup.net>
+Date: Wed, 25 May 2016 02:29:21 +0200
+Subject: [PATCH] p7zip-rar 15.14 supported
+
+since 15.14, p7zip-rar uses the plugin Rar.so to handle archives
+
+It can find on /usr/lib/ or /usr/libexec/
+
+If someone has it in another folder, we can add it
+
+Fixes #136
+---
+ src/fr-command-7z.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/fr-command-7z.c b/src/fr-command-7z.c
+index 20cfa2c..a7d032e 100644
+--- a/src/fr-command-7z.c
++++ b/src/fr-command-7z.c
+@@ -599,7 +599,8 @@ fr_command_7z_get_capabilities (FrCommand *comm,
+ if (is_mime_type (mime_type, "application/x-rar")
+ || is_mime_type (mime_type, "application/x-cbr"))
+ {
+- if (! check_command || g_file_test ("/usr/lib/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS))
++ if (! check_command || g_file_test ("/usr/lib/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS) || g_file_test ("/usr/lib/p7zip/Codecs/Rar.so", G_FILE_TEST_EXISTS)
++ || g_file_test ("/usr/libexec/p7zip/Codecs/Rar29.so", G_FILE_TEST_EXISTS) || g_file_test ("/usr/libexec/p7zip/Codecs/Rar.so", G_FILE_TEST_EXISTS))
+ capabilities |= FR_COMMAND_CAN_READ;
+ }
+ else