summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2af3c36..0e03a5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,11 +5,18 @@ AM_INIT_AUTOMAKE([1.6 foreign dist-bzip2 subdir-objects])
AC_PROG_SED
-# https://bitbucket.org/mgorny/systemd-sdk/
+# https://bitbucket.org/mgorny/systemd-m4/
SYSTEMD_MISC
+
SYSTEMD_SYSTEMUNITDIR
+if test -z "$systemdsystemunitdir"; then
+ AC_MSG_ERROR([systemdsystemunitdir must be set])
+fi
+
SYSTEMD_SYSTEMGENERATORDIR
-SYSTEMD_UTILDIR
+if test -z "$systemdsystemgeneratordir"; then
+ AC_MSG_ERROR([systemdsystemgeneratordir must be set])
+fi
AC_CONFIG_FILES([Makefile])
AC_OUTPUT