aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Bolte <matthias.bolte@googlemail.com>2009-11-13 23:19:09 +0100
committerMatthias Bolte <matthias.bolte@googlemail.com>2009-11-15 15:13:03 +0100
commitdad6ecc6bf7e47bcd98e283aa27699e06ee3e57f (patch)
treefb5f1df60d33c38d0071d423af8753d4def7d18a
parentFix compilation of libvirt against xen-unstable (diff)
downloadlibvirt-dad6ecc6bf7e47bcd98e283aa27699e06ee3e57f.tar.gz
libvirt-dad6ecc6bf7e47bcd98e283aa27699e06ee3e57f.tar.bz2
libvirt-dad6ecc6bf7e47bcd98e283aa27699e06ee3e57f.zip
Change DTD references to use public instead of system identifier
Debian's /etc/xml/catalog doesn't contain system identifiers, so use public identifiers instead. * docs/Makefile.am: use public instead of system identifier * docs/site.xsl: use matching public identifier
-rw-r--r--docs/Makefile.am6
-rw-r--r--docs/site.xsl2
2 files changed, 4 insertions, 4 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index d819869c5..d53f305bd 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -106,7 +106,7 @@ ChangeLog.html.in: ChangeLog.xml ChangeLog.xsl
%.html: %.html.tmp
@(if [ -x $(XMLLINT) -a -x $(XMLCATALOG) ] ; then \
- if $(XMLCATALOG) /etc/xml/catalog "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd" > /dev/null ; then \
+ if $(XMLCATALOG) /etc/xml/catalog "-//W3C//DTD XHTML 1.0 Strict//EN" > /dev/null ; then \
echo "Validating $@" ; \
$(XMLLINT) --nonet --format --valid $< > $@ || : ; \
else echo "missing XHTML1 DTD" ; fi ; fi );
@@ -117,7 +117,7 @@ html/index.html: libvirt-api.xml newapi.xsl page.xsl sitemap.html.in
echo "Rebuilding the HTML pages from the XML API" ; \
$(XSLTPROC) --nonet $(srcdir)/newapi.xsl libvirt-api.xml ; fi )
-@(if [ -x $(XMLLINT) -a -x $(XMLCATALOG) ] ; then \
- if $(XMLCATALOG) /etc/xml/catalog "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd" > /dev/null ; then \
+ if $(XMLCATALOG) /etc/xml/catalog "-//W3C//DTD XHTML 1.0 Strict//EN" > /dev/null ; then \
echo "Validating the resulting XHTML pages" ; \
$(XMLLINT) --nonet --valid --noout html/*.html ; \
else echo "missing XHTML1 DTD" ; fi ; fi );
@@ -159,4 +159,4 @@ uninstall-local:
for h in $(apihtml); do rm $(DESTDIR)$(HTML_DIR)/$$h; done
for p in $(apipng); do rm $(DESTDIR)$(HTML_DIR)/$$p; done
for f in $(devhelphtml) $(devhelppng) $(devhelpcss); do \
- rm $(DESTDIR)$(DEVHELP_DIR)$$f ; done \ No newline at end of file
+ rm $(DESTDIR)$(DEVHELP_DIR)$$f ; done
diff --git a/docs/site.xsl b/docs/site.xsl
index b2983bd8a..86cfd41b1 100644
--- a/docs/site.xsl
+++ b/docs/site.xsl
@@ -11,7 +11,7 @@
method="xml"
encoding="ISO-8859-1"
indent="yes"
- doctype-public="-//W3C//DTD XHTML 1.0//EN"
+ doctype-public="-//W3C//DTD XHTML 1.0 Strict//EN"
doctype-system="http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"/>
<xsl:variable name="href_base" select="''"/>