aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-07-27 13:51:28 +0100
committerDaniel P. Berrange <berrange@redhat.com>2012-07-30 13:09:57 +0100
commit92c5924a05550b4ae36cb45b3d2ebcf1ef67296a (patch)
tree14da57c026ab99f94e8347f596378e81a042a182 /build-aux
parentAdd handling for reboots of LXC containers (diff)
downloadlibvirt-92c5924a05550b4ae36cb45b3d2ebcf1ef67296a.tar.gz
libvirt-92c5924a05550b4ae36cb45b3d2ebcf1ef67296a.tar.bz2
libvirt-92c5924a05550b4ae36cb45b3d2ebcf1ef67296a.zip
Remove tabs from all perl files & enforce this
The cfg.mk file rule to check for tab characters was not applied to perl files. Much of our Perl code is full of tabs as a result. Kill them, kill them all !
Diffstat (limited to 'build-aux')
-rwxr-xr-xbuild-aux/augeas-gentest.pl42
1 files changed, 21 insertions, 21 deletions
diff --git a/build-aux/augeas-gentest.pl b/build-aux/augeas-gentest.pl
index 8b6835701..bbb1bd495 100755
--- a/build-aux/augeas-gentest.pl
+++ b/build-aux/augeas-gentest.pl
@@ -41,28 +41,28 @@ open TEMPLATE, "<", $template or die "cannot read $template: $!";
my $group = 0;
while (<TEMPLATE>) {
if (/::CONFIG::/) {
- my $group = 0;
- print AUGTEST " let conf = \"";
- while (<CONFIG>) {
- if (/^#\w/) {
- s/^#//;
- s/\"/\\\"/g;
- print AUGTEST $_;
- $group = /\[\s$/;
- } elsif ($group) {
- s/\"/\\\"/g;
- if (/#\s*\]/) {
- $group = 0;
- }
- if (/^#/) {
- s/^#//;
- print AUGTEST $_;
- }
- }
- }
- print AUGTEST "\"\n";
+ my $group = 0;
+ print AUGTEST " let conf = \"";
+ while (<CONFIG>) {
+ if (/^#\w/) {
+ s/^#//;
+ s/\"/\\\"/g;
+ print AUGTEST $_;
+ $group = /\[\s$/;
+ } elsif ($group) {
+ s/\"/\\\"/g;
+ if (/#\s*\]/) {
+ $group = 0;
+ }
+ if (/^#/) {
+ s/^#//;
+ print AUGTEST $_;
+ }
+ }
+ }
+ print AUGTEST "\"\n";
} else {
- print AUGTEST $_;
+ print AUGTEST $_;
}
}