aboutsummaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2012-08-12 23:44:47 -0500
committerDaniel Veillard <veillard@redhat.com>2012-08-15 21:40:38 +0800
commit9cdd73a245712a0c91690f4abd8beb2ccc2466e2 (patch)
treedf0e0a6568aa215108f20afb80d099292fed305a /daemon
parentRefactor RPC client private data setup (diff)
downloadlibvirt-9cdd73a245712a0c91690f4abd8beb2ccc2466e2.tar.gz
libvirt-9cdd73a245712a0c91690f4abd8beb2ccc2466e2.tar.bz2
libvirt-9cdd73a245712a0c91690f4abd8beb2ccc2466e2.zip
Fix man page file paths to real paths
Currently the man page has paths that start with @sysconfdir@, @localstatedir@ and @remote_pid_file@. The sed command attempts to replace these during the build but unfortunately pod2man gets to the files first and escapes the @ character resulting in the sed not working. This removes the @ character and makes the paths correct.
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.am6
-rw-r--r--daemon/libvirtd.pod.in18
2 files changed, 12 insertions, 12 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 928aeaf47..c15c785c6 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -85,9 +85,9 @@ CLEANFILES += test_libvirtd.aug
libvirtd.8: $(srcdir)/libvirtd.8.in
sed \
- -e 's![@]sysconfdir[@]!$(sysconfdir)!g' \
- -e 's![@]localstatedir[@]!$(localstatedir)!g' \
- -e 's![@]remote_pid_file[@]!$(REMOTE_PID_FILE)!g' \
+ -e 's!SYSCONFDIR!$(sysconfdir)!g' \
+ -e 's!LOCALSTATEDIR!$(localstatedir)!g' \
+ -e 's!REMOTE_PID_FILE!$(REMOTE_PID_FILE)!g' \
< $< > $@-t
mv $@-t $@
diff --git a/daemon/libvirtd.pod.in b/daemon/libvirtd.pod.in
index 57a3b2707..7dc8d83ea 100644
--- a/daemon/libvirtd.pod.in
+++ b/daemon/libvirtd.pod.in
@@ -77,14 +77,14 @@ On receipt of B<SIGHUP> libvirtd will reload its configuration.
=over
-=item F<@sysconfdir@/libvirtd.conf>
+=item F<SYSCONFDIR/libvirtd.conf>
The default configuration file used by libvirtd, unless overridden on the
command line using the B<-f>|B<--config> option.
-=item F<@localstatedir@/run/libvirt/libvirt-sock>
+=item F<LOCALSTATEDIR/run/libvirt/libvirt-sock>
-=item F<@localstatedir@/run/libvirt/libvirt-sock-ro>
+=item F<LOCALSTATEDIR/run/libvirt/libvirt-sock-ro>
The sockets libvirtd will use when B<run as root>.
@@ -92,19 +92,19 @@ The sockets libvirtd will use when B<run as root>.
The socket libvirtd will use when run as a B<non-root> user.
-=item F<@sysconfdir@/pki/CA/cacert.pem>
+=item F<SYSCONFDIR/pki/CA/cacert.pem>
The TLS B<Certificate Authority> certificate libvirtd will use.
-=item F<@sysconfdir@/pki/libvirt/servercert.pem>
+=item F<SYSCONFDIR/pki/libvirt/servercert.pem>
The TLS B<Server> certificate libvirtd will use.
-=item F<@sysconfdir@/pki/libvirt/private/serverkey.pem>
+=item F<SYSCONFDIR/pki/libvirt/private/serverkey.pem>
The TLS B<Server> private key libvirtd will use.
-=item F<@remote_pid_file@>
+=item F<REMOTE_PID_FILE>
The PID file to use, unless overridden by the B<-p>|B<--pid-file> option.
@@ -121,8 +121,8 @@ To retrieve the version of libvirtd:
To start libvirtd, instructing it to daemonize and create a PID file:
# libvirtd -d
- # ls -la @remote_pid_file@
- -rw-r--r-- 1 root root 6 Jul 9 02:40 @remote_pid_file@
+ # ls -la REMOTE_PID_FILE
+ -rw-r--r-- 1 root root 6 Jul 9 02:40 REMOTE_PID_FILE
#
=head1 BUGS