summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-06-27 07:09:58 -0400
committerMike Pagano <mpagano@gentoo.org>2019-06-27 07:09:58 -0400
commitc1e2dc1d7758b655ec285bb4128862a2863eeea5 (patch)
tree513cf4adc65d5b452090c261beaf709796b3f259
parentLinux patch 4.9.183 (diff)
downloadlinux-patches-c1e2dc1d7758b655ec285bb4128862a2863eeea5.tar.gz
linux-patches-c1e2dc1d7758b655ec285bb4128862a2863eeea5.tar.bz2
linux-patches-c1e2dc1d7758b655ec285bb4128862a2863eeea5.zip
Linux patch 4.9.1844.9-189
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1183_linux-4.9.184.patch25
2 files changed, 29 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index fd038980..0978678f 100644
--- a/0000_README
+++ b/0000_README
@@ -775,6 +775,10 @@ Patch: 1182_linux-4.9.183.patch
From: http://www.kernel.org
Desc: Linux 4.9.183
+Patch: 1183_linux-4.9.184.patch
+From: http://www.kernel.org
+Desc: Linux 4.9.184
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1183_linux-4.9.184.patch b/1183_linux-4.9.184.patch
new file mode 100644
index 00000000..03719111
--- /dev/null
+++ b/1183_linux-4.9.184.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index e63ace93b67b..3b0dd4e90c44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 9
+-SUBLEVEL = 183
++SUBLEVEL = 184
+ EXTRAVERSION =
+ NAME = Roaring Lionus
+
+diff --git a/net/ipv4/tcp_output.c b/net/ipv4/tcp_output.c
+index d8c6b833f0ce..0c195b0f4216 100644
+--- a/net/ipv4/tcp_output.c
++++ b/net/ipv4/tcp_output.c
+@@ -1185,7 +1185,7 @@ int tcp_fragment(struct sock *sk, struct sk_buff *skb, u32 len,
+ if (nsize < 0)
+ nsize = 0;
+
+- if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf)) {
++ if (unlikely((sk->sk_wmem_queued >> 1) > sk->sk_sndbuf + 0x20000)) {
+ NET_INC_STATS(sock_net(sk), LINUX_MIB_TCPWQUEUETOOBIG);
+ return -ENOMEM;
+ }