summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-07-15 06:01:35 -0400
committerMike Pagano <mpagano@gentoo.org>2022-07-15 06:01:35 -0400
commit9f9deae824cffc410ae9526e81a63a80b158b7f0 (patch)
tree10b8a48427c9dcffb3360034b3661a9bae9f725a
parentLinux patch 5.15.54 (diff)
downloadlinux-patches-9f9deae824cffc410ae9526e81a63a80b158b7f0.tar.gz
linux-patches-9f9deae824cffc410ae9526e81a63a80b158b7f0.tar.bz2
linux-patches-9f9deae824cffc410ae9526e81a63a80b158b7f0.zip
Linux patch 5.15.555.15-59
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1054_linux-5.15.55.patch26
2 files changed, 30 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index faf4691f..cc0f4ebb 100644
--- a/0000_README
+++ b/0000_README
@@ -259,6 +259,10 @@ Patch: 1053_linux-5.15.54.patch
From: http://www.kernel.org
Desc: Linux 5.15.54
+Patch: 1054_linux-5.15.55.patch
+From: http://www.kernel.org
+Desc: Linux 5.15.55
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1054_linux-5.15.55.patch b/1054_linux-5.15.55.patch
new file mode 100644
index 00000000..997e167b
--- /dev/null
+++ b/1054_linux-5.15.55.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index f8dc156aa3021..c95f0f59885fd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 15
+-SUBLEVEL = 54
++SUBLEVEL = 55
+ EXTRAVERSION =
+ NAME = Trick or Treat
+
+diff --git a/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c b/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
+index 6eb0677777037..b72b387c08ef7 100644
+--- a/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
++++ b/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
+@@ -685,7 +685,7 @@ static void gpmi_nfc_compute_timings(struct gpmi_nand_data *this,
+ hw->timing0 = BF_GPMI_TIMING0_ADDRESS_SETUP(addr_setup_cycles) |
+ BF_GPMI_TIMING0_DATA_HOLD(data_hold_cycles) |
+ BF_GPMI_TIMING0_DATA_SETUP(data_setup_cycles);
+- hw->timing1 = BF_GPMI_TIMING1_BUSY_TIMEOUT(DIV_ROUND_UP(busy_timeout_cycles, 4096));
++ hw->timing1 = BF_GPMI_TIMING1_BUSY_TIMEOUT(busy_timeout_cycles * 4096);
+
+ /*
+ * Derive NFC ideal delay from {3}: