diff options
author | Mike Frysinger <vapier@gentoo.org> | 2012-01-23 23:47:14 +0000 |
---|---|---|
committer | Mike Frysinger <vapier@gentoo.org> | 2012-01-23 23:47:14 +0000 |
commit | c93013459823567655b4ddfd996f90bf1db7d7fc (patch) | |
tree | 8e0bfeff372538444ec6409cad44798bf8de820f | |
parent | clarify --ldcache help option (diff) | |
download | pax-utils-c93013459823567655b4ddfd996f90bf1db7d7fc.tar.gz pax-utils-c93013459823567655b4ddfd996f90bf1db7d7fc.tar.bz2 pax-utils-c93013459823567655b4ddfd996f90bf1db7d7fc.zip |
fix `make debug -j` so that it works and doesnt do "all" then "clean"
-rw-r--r-- | Makefile | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -1,6 +1,6 @@ # Copyright 2003-2006 Ned Ludd <solar@linbsd.net> # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.76 2011/03/03 21:08:04 vapier Exp $ +# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.77 2012/01/23 23:47:14 vapier Exp $ #################################################################### check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \ @@ -58,8 +58,8 @@ SOURCES = $(OBJS:%.o=%.c) all: $(OBJS) $(TARGETS) @: -debug: - $(MAKE) CFLAGS="$(CFLAGS) -g3 -ggdb $(call check-gcc,-nopie)" clean all +debug: clean + $(MAKE) CFLAGS="$(CFLAGS) -g3 -ggdb $(call check-gcc,-nopie)" all @-/sbin/chpax -permsx $(ELF_TARGETS) @-/sbin/paxctl -permsx $(ELF_TARGETS) |