aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiezhiko <Miezhiko@gmail.com>2022-01-18 11:24:25 +0400
committerHorea Christian <chr@chymera.eu>2022-01-18 11:03:19 -0500
commit18aaa9f314ed173897168c6a4d934edfaed12951 (patch)
treecdc93b2b2fc51931e55c325d53976851051afb6f /sci-libs/pydicom
parentdev-python/numba: bump version to 0.55.0 (diff)
downloadsci-18aaa9f314ed173897168c6a4d934edfaed12951.tar.gz
sci-18aaa9f314ed173897168c6a4d934edfaed12951.tar.bz2
sci-18aaa9f314ed173897168c6a4d934edfaed12951.zip
sci-libs/pydicom: update to 2.2.2, py3.10 support
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miezhiko <Miezhiko@gmail.com> Closes: https://github.com/gentoo/sci/pull/1139 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/pydicom')
-rw-r--r--sci-libs/pydicom/Manifest1
-rw-r--r--sci-libs/pydicom/pydicom-2.2.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/pydicom/Manifest b/sci-libs/pydicom/Manifest
index 90e3ca3eb..b49bf81e1 100644
--- a/sci-libs/pydicom/Manifest
+++ b/sci-libs/pydicom/Manifest
@@ -1,2 +1,3 @@
DIST pydicom-1.1.0.tar.gz 6724086 BLAKE2B efdcdd722bc877b9b9cf137ecd2a3fa6fb2b7da022bdab49f03dbcdb5a3e3dc8bc24b6b0d8eb9ab946934ec182c13ec1df671461c357476f543afb6f435f604c SHA512 ffca9eb4333d29accea1d6e5a5b4c3c0bd0f8c12fdf00c5c84d83769db621e8f348c9200dff1dc1cd6016cbf5d76b00f08c3b112ba653433a84ce31ad1ab33d5
DIST pydicom-1.4.2.tar.gz 35237997 BLAKE2B 0b4db847150153519cc7d805a9a7b9c5c4d9ed46496bd561a24e5ede1cd3b5f176581a9741aba65c31cdd0533fb6a33905cc21003f0237c7cd7e603ef672c67a SHA512 8fc0a2e5f0a8578b98d49b749912cca98d51bdcae2b3bd5759e03e13cd2a2d4f45ce0e2a22d80526abfa5f428a4a71b5fad2c9f36bafc4f3fa2866cd687ac015
+DIST pydicom-2.2.2.tar.gz 2149674 BLAKE2B d109975c6ac0081a02c534bb014040ca767968d276fb841a0000ab4f7b4884ab604276b7092f8cc699d24d0429426cf5be3225ae56b8b8ebdad89cf541ab065a SHA512 5f1829d445c462884debb75328f59471dea4da51701835a3a97a1c22c1c0b75730e0688558cb76ef3f7a4b29f350028190a515d73f88968a7fda09ed414ec145
diff --git a/sci-libs/pydicom/pydicom-2.2.2.ebuild b/sci-libs/pydicom/pydicom-2.2.2.ebuild
new file mode 100644
index 000000000..f36be3a78
--- /dev/null
+++ b/sci-libs/pydicom/pydicom-2.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python package for parsing DICOM files"
+HOMEPAGE="http://www.pydicom.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Upstream bug: https://github.com/pydicom/pydicom/issues/663
+RESTRICT="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ distutils-r1_install_for_testing
+ py.test --cov=pydicom -r sx --pyargs pydicom --verbose || die
+}