aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-18 13:17:16 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-19 16:47:17 +0100
commit9344a45969aa7cdc27c86c10c17455fabc6a3437 (patch)
tree3c27d288540d65e02bac1d2a769a5788e714bf17 /sci-physics
parentsci-physics/pyhepmc: new package, add 2.11.0 (diff)
downloadsci-9344a45969aa7cdc27c86c10c17455fabc6a3437.tar.gz
sci-9344a45969aa7cdc27c86c10c17455fabc6a3437.tar.bz2
sci-9344a45969aa7cdc27c86c10c17455fabc6a3437.zip
sci-physics/hoppet: new package, add 1.2.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/sci/pull/1242
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/hoppet/Manifest1
-rw-r--r--sci-physics/hoppet/hoppet-1.2.0.ebuild35
-rw-r--r--sci-physics/hoppet/metadata.xml19
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-physics/hoppet/Manifest b/sci-physics/hoppet/Manifest
new file mode 100644
index 000000000..cc73bfc3b
--- /dev/null
+++ b/sci-physics/hoppet/Manifest
@@ -0,0 +1 @@
+DIST hoppet-1.2.0.tgz 575911 BLAKE2B 4d4dc1874b45b7237384ad3955808b5f4995c86b4d44165ef0c4d8b1da21880cdd1a3f1f1537f02ad7928baef5207e950be411465989ab876bcb806f355725cf SHA512 65ceb170cd417f229f8a974aa995138b8ee7ea5ef04538a5382b353181951e9d4489045234cd45c1ea8f88a5faf4755e3a0e246065711f137676bbf726a29f1f
diff --git a/sci-physics/hoppet/hoppet-1.2.0.ebuild b/sci-physics/hoppet/hoppet-1.2.0.ebuild
new file mode 100644
index 000000000..337881026
--- /dev/null
+++ b/sci-physics/hoppet/hoppet-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+DESCRIPTION="Higher Order Perturbative Parton Evolution Toolkit"
+HOMEPAGE="
+ https://hoppet.hepforge.org/
+ https://github.com/gavinsalam/hoppet
+"
+SRC_URI="https://hoppet.hepforge.org/downloads/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+
+
+src_configure() {
+ default
+ # own custom configure
+ ./configure --prefix="${EPREFIX}"/usr FFLAGS="${FFLAGS} -fPIC" || die
+}
+
+src_install() {
+ # Fix install to ED
+ sed -i "s#scripts/install-sh hoppet-config#\##g" Makefile || die
+ sed -i "s#/usr/lib/libhoppet#${ED}/usr/$(get_libdir)/libhoppet#g" src/Makefile || die
+ sed -i "s#/usr/include/hoppet#${ED}/usr/include/hoppet#g" src/Makefile || die
+ emake install
+ emake install-mod
+ dobin hoppet-config
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/hoppet/metadata.xml b/sci-physics/hoppet/metadata.xml
new file mode 100644
index 000000000..37900a238
--- /dev/null
+++ b/sci-physics/hoppet/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ HOPPET is a Fortran 95 package for carrying out DGLAP evolution and other common manipulations of parton distribution functions (PDFs).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gavinsalam/hoppet</remote-id>
+ </upstream>
+</pkgmetadata>