aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-27 15:08:07 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-27 16:30:41 +0100
commitfded3a905e1414233d7d90fe95ad7e2affdc1bdb (patch)
tree6e834a69224f9ff171d15ae66b6cbecef1da6438 /sci-physics
parentsci-physics/lhapdf-sets: Add more PDFs (diff)
downloadsci-fded3a905e1414233d7d90fe95ad7e2affdc1bdb.tar.gz
sci-fded3a905e1414233d7d90fe95ad7e2affdc1bdb.tar.bz2
sci-fded3a905e1414233d7d90fe95ad7e2affdc1bdb.zip
sci-physics/apfelxx: new package, add 4.8.0
Closes: https://github.com/gentoo/sci/pull/1247 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/apfelxx/Manifest1
-rw-r--r--sci-physics/apfelxx/apfelxx-4.8.0.ebuild39
-rw-r--r--sci-physics/apfelxx/metadata.xml18
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-physics/apfelxx/Manifest b/sci-physics/apfelxx/Manifest
new file mode 100644
index 000000000..b461f2a76
--- /dev/null
+++ b/sci-physics/apfelxx/Manifest
@@ -0,0 +1 @@
+DIST apfelxx-4.8.0.tar.gz 21695802 BLAKE2B f28d28bafed79ec679fd44bbd3cba668b108668dceaffbc80091a022d1884121a9d2fb08e89ae439663765877aadb7c214b6196d2ea35ad8c25ba545ec3492ee SHA512 23fcde7262637cbe0ff0173a530d0e2d3f39a9daa8b8757e4769c41c4af72569b0e0b8ab59ad5a8dc08ec7718d40bd34abed66671d2116f4242d06b6c2e7c1cc
diff --git a/sci-physics/apfelxx/apfelxx-4.8.0.ebuild b/sci-physics/apfelxx/apfelxx-4.8.0.ebuild
new file mode 100644
index 000000000..d31224fa3
--- /dev/null
+++ b/sci-physics/apfelxx/apfelxx-4.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Object oriented rewriting of the APFEL evolution code"
+HOMEPAGE="https://github.com/vbertone/apfelxx"
+SRC_URI="https://github.com/vbertone/apfelxx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+ cmake_src_prepare
+ sed -i "/prefix./s/\/lib/\/$(get_libdir)/g" CMakeLists.txt || die
+ sed -i "s#DESTINATION lib#DESTINATION $(get_libdir)#g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
diff --git a/sci-physics/apfelxx/metadata.xml b/sci-physics/apfelxx/metadata.xml
new file mode 100644
index 000000000..27c6de8e1
--- /dev/null
+++ b/sci-physics/apfelxx/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ APFEL++ is a C++ rewriting of the Fortran 77 evolution code APFEL. However, APFEL++ is based on a completely new code design and guarantees a better performance along with a more optimal memory management. The new modular structure allows for better maintainability and easier extensibility. This makes APFEL++ suitable for a wide range of tasks: from the solution of the DGLAP evolution equations to the computation of deep-inelastic-scattering (DIS) and single-inclusive-annihilation cross sections. Also more complex computations, such as differential semi-inclusive DIS and Drell-Yan cross sections, are easily implementable in APFEL++.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vbertone/apfelxx</remote-id>
+ </upstream>
+</pkgmetadata>