aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pydicom/pydicom-1.4.2.ebuild')
-rw-r--r--sci-libs/pydicom/pydicom-1.4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/pydicom/pydicom-1.4.2.ebuild b/sci-libs/pydicom/pydicom-1.4.2.ebuild
new file mode 100644
index 000000000..2ab96e750
--- /dev/null
+++ b/sci-libs/pydicom/pydicom-1.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python package for parsing DICOM files"
+HOMEPAGE="http://www.pydicom.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ distutils-r1_install_for_testing
+ py.test -r sx --pyargs pydicom --verbose || die
+}