aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2011-04-08 02:41:42 +0200
committerDiego Elio Pettenò <flameeyes@gmail.com>2011-04-08 02:41:42 +0200
commitde2d622802825639ac67969a44f1f01b4fe04187 (patch)
tree054d9a45bd5b2d9bcd088d43188fdd62b01ced1f
parentbuild: allow easy override of GCC_BASE (diff)
downloadsparse-de2d622802825639ac67969a44f1f01b4fe04187.tar.gz
sparse-de2d622802825639ac67969a44f1f01b4fe04187.tar.bz2
sparse-de2d622802825639ac67969a44f1f01b4fe04187.zip
build: don't override CFLAGS in environment.
This allows proper setting of flags by having them in the environment, rather than overriding them on the make command line (which would then also drop the required flags for building sparse.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 67d5ee6..99b50bd 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ OS = linux
CC = gcc
-CFLAGS = -O2 -finline-functions -fno-strict-aliasing -g
+CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
CFLAGS += -Wall -Wwrite-strings
LDFLAGS += -g
AR = ar