summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2010-12-03 15:05:47 +0100
committerThomas Kahle <tom111@gmx.de>2010-12-03 15:05:47 +0100
commitb118ad4a2442c74631b30d919f8b4fa1b0be45c6 (patch)
tree25e2c93f99cd3fdcba63fc85e6f18e3dc1011805 /templates
parentUsing the print-function instead of the statement (diff)
downloadtatt-b118ad4a2442c74631b30d919f8b4fa1b0be45c6.tar.gz
tatt-b118ad4a2442c74631b30d919f8b4fa1b0be45c6.tar.bz2
tatt-b118ad4a2442c74631b30d919f8b4fa1b0be45c6.zip
adding the 'templates' package
Diffstat (limited to 'templates')
-rw-r--r--templates/__init__.py0
-rw-r--r--templates/commit.sh33
-rw-r--r--templates/revdep-header2
-rw-r--r--templates/revdep-snippet4
-rw-r--r--templates/use-header1
-rw-r--r--templates/use-snippet4
6 files changed, 44 insertions, 0 deletions
diff --git a/templates/__init__.py b/templates/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/templates/__init__.py
diff --git a/templates/commit.sh b/templates/commit.sh
new file mode 100644
index 0000000..a021eb0
--- /dev/null
+++ b/templates/commit.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+
+# Drop initial -m if given
+[[ "${1}" == "-m" ]] && shift
+
+[[ -z "${1}" ]] && {
+ echo " *** missing change description"
+ exit 1
+}
+
+[[ -z "$(cvs up 2>&1 | grep '^[MAR]')" ]] && {
+ echo " *** no changes!"
+ exit 1
+}
+
+message="${1}"
+echo "Using commit message:"
+echo "${message}"
+
+rm -f ChangeLog
+cvs up ChangeLog 2>&1 | grep -v "cvs update: warning: \`ChangeLog' was lost"
+
+echangelog "${message}" || {
+ echo " *** echangelog failed"
+ exit 1
+}
+
+ebuild $(\ls -1 *.ebuild | tail -n 1) manifest
+repoman full || {
+ echo " *** repoman failed"
+ exit 1
+}
+repoman -m "${message}" commit
diff --git a/templates/revdep-header b/templates/revdep-header
new file mode 100644
index 0000000..bd16e49
--- /dev/null
+++ b/templates/revdep-header
@@ -0,0 +1,2 @@
+#!/bin/sh
+# Reverse dependency testing for @@CPV@@ \ No newline at end of file
diff --git a/templates/revdep-snippet b/templates/revdep-snippet
new file mode 100644
index 0000000..7c46952
--- /dev/null
+++ b/templates/revdep-snippet
@@ -0,0 +1,4 @@
+if FEATURES="@@FEATURES@@" USE="@@USE@@" emerge -1v @@CPV@@; then
+echo "FEATURES='@@FEATURES@@' USE='@@USE@@' emerge -1v @@CPV@@" succeeded >> @@REPORTFILE@@;
+else echo "FEATURES='@@FEATURES@@' USE='@@USE@@' emerge -1v @@CPV@@" failed >> @@REPORTFILE@@;
+fi;
diff --git a/templates/use-header b/templates/use-header
new file mode 100644
index 0000000..203bc3a
--- /dev/null
+++ b/templates/use-header
@@ -0,0 +1 @@
+#!/bin/sh # USE-Flag build tests for Code for @@CPV@@ \ No newline at end of file
diff --git a/templates/use-snippet b/templates/use-snippet
new file mode 100644
index 0000000..acd5aab
--- /dev/null
+++ b/templates/use-snippet
@@ -0,0 +1,4 @@
+if USE="@@USE@@" FEATURES="@@FEATURES@@" emerge -1v @@CPV@@ ; then
+ echo "USE='@@USE@@' FEATURES='@@FEATURES@@' succeeded for @@CPV@@ >> @@REPORTFILE@@ ;
+else echo "USE='@@USE@@' FEATURES='@@FEATURES@@' failed for @@CPV@@" >> @@REPORTFILE@@;
+fi;