summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20200609_rc3.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index 0921963..f7d0729 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,4 +1,3 @@
DIST dokuwiki-2018-04-22b.tgz 3745314 BLAKE2B 56c349c72038db83b5ae199ac1d6d00ef8566a00fdf2bc5a782e808e5205ae3ba5cfa47bdfc4f7fb0b2e493a22eed006517cfb46f7c0c57de748cfb800942f58 SHA512 6fc1fba8d93296d7cc795a4067e409339b3ce965ad38aefa42f1974d267ac05f199185e895a60d355ebe8371c68345fa51f2aea5871f955dbba1cdbdf8bedebf
DIST dokuwiki-2018-04-22c.tgz 3745201 BLAKE2B 13d8fb906136bed56a1a267a9999579521664c05904d08548afe36c73321e51d09b6e0a547852588a992014a10005ec8410ef834e6c1a0730215e6b7be7841c7 SHA512 aa6e97a04b92095132b2cc7a1e9f00df3ff97069198868d6da805fc97694ed8528dee919fc9752c0187df0c982337ad5a2f85991ca08592dd6d4d4114644668b
DIST dokuwiki-2020-07-29.tgz 3821413 BLAKE2B bd14ec2450365befb85afdefc6bb078f10bdf1659d85adac3bbb2f502d29f3e706fb277d65810103e66b0c692f7166ed3c8d9e780489c08fb7ef9695de550d75 SHA512 093474bf5d5bb2c95400692927cbc8ffbe7666f178ffaa648a043ef05a2b32471feeed5de282c36b41e6e80e0a065909ea2ced8ecffc7fb339bda902697d596c
-DIST dokuwiki-20200609_rc3.tgz 3817634 BLAKE2B 138aae6e7fe60e08fe22119e6aa8e968412663fab2714b5dc4d794108bfdb43b74fb6dd1e078347f790f579639448f8419839a699e0bb1250bddaa92e18ea5f4 SHA512 13fdde3de9d7570d49fd2dbbcea1a18fd1db0f2f462d239e872cd71a77a53270577ac4e3ed24db91923132a46aeb33037e581b7f5f1bcb9ced02b4acd966e42e
diff --git a/www-apps/dokuwiki/dokuwiki-20200609_rc3.ebuild b/www-apps/dokuwiki/dokuwiki-20200609_rc3.ebuild
deleted file mode 100644
index 9c0d761..0000000
--- a/www-apps/dokuwiki/dokuwiki-20200609_rc3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-
-if [[ ${PV} == *rc* ]]; then
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- MY_P="${PN}-rc-${MY_BASE_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
-else
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="https://wiki.dokuwiki.org"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-5.3[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-
- default
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}