summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-03 18:11:25 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-03 18:11:45 -0400
commit9aa8c5e0dcce5109977ae9ee3e7dbd22ba09c153 (patch)
treec8ff548441ec59630015bcd4c81f65b488333649
parentdev-ruby/bcrypt-ruby: Remove ruby19 (diff)
downloadgentoo-9aa8c5e0dcce5109977ae9ee3e7dbd22ba09c153.tar.gz
gentoo-9aa8c5e0dcce5109977ae9ee3e7dbd22ba09c153.tar.bz2
gentoo-9aa8c5e0dcce5109977ae9ee3e7dbd22ba09c153.zip
app-backup/spideroak-bin: version bump to 6.1.3
Package-Manager: portage-2.2.26
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-6.1.3.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index d105f61109e0..ce0f6c91a114 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -4,3 +4,5 @@ DIST spideroak-bin-5.2.0_amd64.deb 20284404 SHA256 f9b452f891796fcd1046c4a955d2b
DIST spideroak-bin-5.2.0_x86.deb 19641884 SHA256 f4689dcc0630e4b46b039c64a16e291d740cc245b7507863ae5938473f504c30 SHA512 e98041b98c77e011774abe5b832c9a2ee4ecd179864bd39aacdb439f906110797f9f96e7326a394a6da0cbb88650c242da51060b501de0c379a0efdb75594403 WHIRLPOOL bf96a2cd8f3bbf6ab2ec26c532546b8c40dda09a1902075332fb2c8787af4a4a1808094fb6e7fb90f27c9da2d480b1129e235fa656c76bd1acbfd3b8bbda90d5
DIST spideroak-bin-6.0.1_amd64.deb 26718286 SHA256 7baa2573756ce174fbdff882be21de2306580de12d31cf760b706da72efdb711 SHA512 28551b5a5e7824e06c17a7f53a9218d82a18ddc9c9ba3bd19361eef02d02afb795ee75d4aad9819ff87de78193edca1015efcea0c65e36bcdfad9d9bdf96f819 WHIRLPOOL dd34a78a675beb8c08c7c36abc6fb65182dcb24ec9a446cc6fc6bb8114f457c2383743305eb3d5886ddb0d9cc3a4dc3489d75fef2226947660f19624b81b5098
DIST spideroak-bin-6.0.1_x86.deb 26232394 SHA256 084013d54c335e74fb853b74f54ac1ca2a90d96338cb6e3dbdf4f83dc718c611 SHA512 b94363fa66338be4af70ac753c7aac0e80dac6bea2a23310075de4e77c950fb67a63e9c6aa14734f00d49ea8a537b788379d3599dfa874fddc9f7455e805f773 WHIRLPOOL 7a735006f179ef1421cc071ebe7118650a6052f5563735beb290021420ef75730f2f105d2606f42a4721d48775eced463e9ca9da58315efae2b9e5c95087bf98
+DIST spideroak-bin-6.1.3_amd64.deb 26655852 SHA256 65ecab3096e6de675fd9facf81f387775c2419158112c4914447fa0af07d8015 SHA512 f9d4e4178721609ec4a544ac8b84e581088ad9be5aaf3aa68de12e2d7e17d7c148d9a619917b69ecfd9c08087d1987b0b67081673b81f56908089caa9ab0edc5 WHIRLPOOL 6751d84d9739bc66f189b52cf944544213f10e978b9e2cb1b85fcf1303fb4ae0373d7bf9633638586cceea659c2448a442b459fdaefc7306854f8b1f58c189d9
+DIST spideroak-bin-6.1.3_x86.deb 26173318 SHA256 50fd7d442291bb9ec64d51308444c83b7d76d55bafcc3e9f5d3009e6a49eee0f SHA512 0ddf1be909b44042e3fe0f7e791558e50c649a3d4472c3a05c78835c593d6db3369c0e862b79f2a4812232503346defc1c889fbc4c701a125d3364810b524481 WHIRLPOOL 2e19e4ac0f9028acea19eb2f395faba2031959c09544c07a7f10c690f67317558ac0fbdf2e1fe1b52a922e4ac9480486348b0c4cf053b03336018d3aef7f2dab
diff --git a/app-backup/spideroak-bin/spideroak-bin-6.1.3.ebuild b/app-backup/spideroak-bin/spideroak-bin-6.1.3.ebuild
new file mode 100644
index 000000000000..b31ccc43bc13
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-6.1.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils unpacker
+
+SRC_URI_BASE="https://spideroak.com/getbuild?platform=ubuntu"
+
+DESCRIPTION="Secure free online backup, storage, access and sharing system"
+HOMEPAGE="https://spideroak.com"
+SRC_URI="x86? ( ${SRC_URI_BASE}&arch=i386&version=${PV} -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}&arch=x86_64&version=${PV} -> ${P}_amd64.deb )"
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}