summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/cpulimit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/cpulimit')
-rw-r--r--app-admin/cpulimit/Manifest1
-rw-r--r--app-admin/cpulimit/cpulimit-1.8.ebuild30
-rw-r--r--app-admin/cpulimit/files/cpulimit.849
-rw-r--r--app-admin/cpulimit/metadata.xml11
4 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/cpulimit/Manifest b/app-admin/cpulimit/Manifest
new file mode 100644
index 000000000000..2830b644946a
--- /dev/null
+++ b/app-admin/cpulimit/Manifest
@@ -0,0 +1 @@
+DIST cpulimit-1.8.tar.gz 20610 SHA256 8d0cdc3ec3e462f2ddc6debb195e1a4e7a19cce8233211f473d921f1c517d5f5 SHA512 3098236139b092eb706ec2a6b84528a090b3f4b8b3adfc8debda1b92ffa119ed9adc508898e0f98add593561f5f6b67d52e0966de01a682a6e2e885e3c47b0fa WHIRLPOOL f9be855b9a4b010c8456c2841afc3551a9a28bfc4a9ec3211e2c1e312bf43cdce9e1b745cc325342433feca5a73df03860469ea3a966d3bd37f7ad11a1627510
diff --git a/app-admin/cpulimit/cpulimit-1.8.ebuild b/app-admin/cpulimit/cpulimit-1.8.ebuild
new file mode 100644
index 000000000000..2b101c19826b
--- /dev/null
+++ b/app-admin/cpulimit/cpulimit-1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Limits the CPU usage of a process"
+HOMEPAGE="http://cpulimit.sourceforge.net"
+SRC_URI="mirror://sourceforge/limitcpu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ tc-export CC
+ # set correct VERSION
+ sed -i -e '/^#define VERSION/s/1.7/1.8/' cpulimit.c || die 'sed on VERSION string failed'
+}
+
+src_install() {
+ dosbin ${PN}
+ doman "${FILESDIR}/${PN}.8"
+}
diff --git a/app-admin/cpulimit/files/cpulimit.8 b/app-admin/cpulimit/files/cpulimit.8
new file mode 100644
index 000000000000..8e6dcf9bbf42
--- /dev/null
+++ b/app-admin/cpulimit/files/cpulimit.8
@@ -0,0 +1,49 @@
+.TH CPULIMIT "8" "July 2006" "cpulimit" "System Management"
+.SH NAME
+cpulimit -- limits the CPU usage of a process
+.SH SYNOPSIS
+.B cpulimit
+\fITARGET \fR[\fIOPTIONS\fR...]
+.SH DESCRIPTION
+.P
+\fITARGET \fRmust be exactly one of these:
+.TP
+\fB\-p\fR, \fB\-\-pid\fR=\fIN\fR
+pid of the process
+.TP
+\fB\-e\fR, \fB\-\-exe\fR=\fIFILE\fR
+name of the executable program file
+.TP
+\fB\-P\fR, \fB\-\-path\fR=\fIPATH\fR
+absolute path name of the executable program file
+.P
+\fIOPTIONS\fR
+.TP
+\fB\-l\fR, \fB\-\-limit\fR=\fIN\fR
+percentage of CPU allowed from 0 to 100 (mandatory)
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+show control statistics
+.TP
+\fB\-z\fR, \fB\-\-lazy\fR
+exit if there is no suitable target process, or if it dies
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+display this help and exit
+.SH EXAMPLES
+Assuming you have started \fB`foo \-\-bar`\fR and you find out with \fItop\fR(1) or
+\fIps\fR(1) that this process uses all your CPU time you can either
+.TP
+\[sh] \fBcpulimit \-e foo \-l 50\fR
+limits the CPU usage of the process by acting on the executable program file
+(note: the argument "\-\-bar" is omitted)
+.TP
+\[sh] \fBcpulimit \-p 1234 \-l 50\fR
+limits the CPU usage of the process by acting on its PID, as shown by
+\fIps\fR(1)
+.TP
+\[sh] \fBcpulimit \-P /usr/bin/foo \-l 50\fR
+same as \fI\-e\fR but uses the absolute path name
+.SH AUTHOR
+This manpage was written for the Debian project by gregor herrmann
+<gregor+debian@comodo.priv.at> but may be used by others.
diff --git a/app-admin/cpulimit/metadata.xml b/app-admin/cpulimit/metadata.xml
new file mode 100644
index 000000000000..39e355636da9
--- /dev/null
+++ b/app-admin/cpulimit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nullishzero@gentoo.org</email>
+ <name>Pavel Kazakov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">limitcpu</remote-id>
+ </upstream>
+</pkgmetadata>