summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-12-22 10:30:06 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-12-22 11:01:47 +0100
commit4d971e4899ea4c7a49c373822cbf3e3244d7741a (patch)
tree8a06f2f9a1e057e7eb27f65ed0ac4cf3fe56ef4d /app-admin/newsyslog
parentdev-libs/libtomcrypt: Fix linking to math libs (diff)
downloadgentoo-4d971e4899ea4c7a49c373822cbf3e3244d7741a.tar.gz
gentoo-4d971e4899ea4c7a49c373822cbf3e3244d7741a.tar.bz2
gentoo-4d971e4899ea4c7a49c373822cbf3e3244d7741a.zip
app-admin/newsyslog: EAPI 7 bump.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/newsyslog')
-rw-r--r--app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild b/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild
new file mode 100644
index 000000000000..9b51143e7783
--- /dev/null
+++ b/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a highly configurable program for managing and archiving log files"
+HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
+SRC_URI="http://download.openpkg.org/components/cache/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ sys-apps/groff"
+
+RDEPEND="
+ virtual/cron
+ app-arch/gzip"
+
+PATCHES=( "${FILESDIR}/${P}-html.patch" )
+
+DOCS=( newsyslog.conf AUTHORS ChangeLog INSTALL NEWS ToDo )
+
+src_configure() {
+ local myconf="--with-syslogd_pid=/var/run/syslog.pid"
+
+ if has_version 'app-admin/syslog-ng'; then
+ myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
+ fi
+
+ econf \
+ --with-gzip \
+ --with-newsyslog_conf=/etc/newsyslog.conf \
+ ${myconf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ catmandir="${T}"/dont-install \
+ install
+ einstalldocs
+}