summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/tardelta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/tardelta')
-rw-r--r--app-arch/tardelta/Manifest1
-rw-r--r--app-arch/tardelta/metadata.xml10
-rw-r--r--app-arch/tardelta/tardelta-1.0.1.ebuild23
3 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/tardelta/Manifest b/app-arch/tardelta/Manifest
new file mode 100644
index 000000000000..2d0c43e1f6e6
--- /dev/null
+++ b/app-arch/tardelta/Manifest
@@ -0,0 +1 @@
+DIST tardelta-1.0.1.tar.gz 3672 SHA256 49a8057d304bbe9d916ba3a3331f63e304f84846538ebe1bb23e6bc706749f69 SHA512 e2ef4fffd484c8e76d2c8b2c148e31e8af8dc6ff7d11625375c50353898f3051b22c4c36bd2c8eb9f3aee4fd5009d0b6a133eccf605ef3d50c27f381af17de57 WHIRLPOOL 0c33e634ab18fa7572d6f63b42fe0ee739fbcff0ed325b21989a4c3c77902887e071e1986e1afc16fe58333734c566ff0b26d07862ea159f2b93fff0e68741a6
diff --git a/app-arch/tardelta/metadata.xml b/app-arch/tardelta/metadata.xml
new file mode 100644
index 000000000000..f5453e0a6cd0
--- /dev/null
+++ b/app-arch/tardelta/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">zmedico/tardelta</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/tardelta/tardelta-1.0.1.ebuild b/app-arch/tardelta/tardelta-1.0.1.ebuild
new file mode 100644
index 000000000000..3552e82f4442
--- /dev/null
+++ b/app-arch/tardelta/tardelta-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate a tarball of differences between two tarballs"
+HOMEPAGE="https://github.com/zmedico/tardelta"
+SRC_URI="https://github.com/zmedico/tardelta/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i "s:^\(__version__ =\).*:\\1 \"${PV}\":" src/${PN}.py || die
+ distutils-r1_src_prepare
+}