summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-02-01 17:48:37 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-02-01 17:48:37 -0800
commitbe423e7fd3af38288f283aea91c255d7ec6bea48 (patch)
tree7688d4dac798f0884a897125f6576b887dffdc8f /app-misc/tmuxp
parentdev-util/intel-graphics-compiler: depend on correct intel-vc-intrinsics (diff)
downloadgentoo-be423e7fd3af38288f283aea91c255d7ec6bea48.tar.gz
gentoo-be423e7fd3af38288f283aea91c255d7ec6bea48.tar.bz2
gentoo-be423e7fd3af38288f283aea91c255d7ec6bea48.zip
app-misc/tmuxp: add 1.27.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.27.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 5eccc1bbdb2f..57148cbee89c 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -2,3 +2,4 @@ DIST tmuxp-1.15.0.tar.gz 842727 BLAKE2B 7e0e68ae848fdefab46a936511f57a9927b28a22
DIST tmuxp-1.24.1.tar.gz 856989 BLAKE2B c809ecc13f29384a43097e10fe7cad15381f50e8962050e7cd8af46e69f422ecb0d4e714555779a85cb72a4be879ef21fdecc207f6321286664a1f81024a1574 SHA512 153505b2e4c2a357c8d73ef6dbd592225a77e32d42165ff1ff80a74b9f52b77cf2d3abe59e9065c3414ce40a32a8a22b63395c9ae958ed14e73a3c03ce1382fb
DIST tmuxp-1.25.0.tar.gz 857012 BLAKE2B d472e0bc34b12f6aac87a0f608ec1e78f52bb54c9e068c5fec53fb8a9a0f70041831dc62a070b4d0f81788f8bd4a0d1f1cb3e45a2d744aa010bf3ecd988e2f6c SHA512 a18dfe4a1df22fc76fb70c7ff06bda6d55a3ffafb21eb26a5ff6fb131452d5a4e2677ca1c3f58c9c6b237b6a9791a3c904f6535a2fcd7dbc1dde28da8959a3fa
DIST tmuxp-1.26.0.tar.gz 861185 BLAKE2B 348cb2f8dfa53f8e541df0fdd2f4cd51b7230485185000a3df5d66fba26adecb159421cd1b3553e433020334c8162b7325bd2ebe499dc8788cbdc5e21a468ee7 SHA512 68459379df6918651100ba5a6c183c46b2f354bed0c484415edf0137f118f74c4104677bbcf8ba1c2fdbae8ca4259ddf756282583ef8d1408e456a016ea9c174
+DIST tmuxp-1.27.0.tar.gz 862056 BLAKE2B baad339bc59498d26911507f29de38d55991515e03123edc8dca10159fed1492c1ffe37cf45d6d04ffc73134e0ee312c0ace2ffc53ba9cae258239746169e416 SHA512 a9c450c40a40c284c609011d5e47b12ed1a9b1d5c4036b887df7fd75a3bb6263847c459a7e61fc9dcdb463a3ac20de6ac9038b1559369a5f36641ab0baee755d
diff --git a/app-misc/tmuxp/tmuxp-1.27.0.ebuild b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
new file mode 100644
index 000000000000..9a1ee04e2a23
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.21.0*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}