summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-26 09:25:02 +0200
committerSam James <sam@gentoo.org>2022-10-31 17:39:48 +0000
commitdf16ce2ac71beb4c015e94915e73c49b03258aac (patch)
tree57041ca28d78b5269bc5706173b7136265ecdb1b /app-misc
parentapp-shells/esh: revbump, fix build to work with clang16 (diff)
downloadgentoo-df16ce2ac71beb4c015e94915e73c49b03258aac.tar.gz
gentoo-df16ce2ac71beb4c015e94915e73c49b03258aac.tar.bz2
gentoo-df16ce2ac71beb4c015e94915e73c49b03258aac.zip
app-misc/gtk-sunlight: revbump, fix clang16 build, EAPI bump
Fix function declarations so clang16 does not complain. Closes: https://bugs.gentoo.org/874717 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/27956 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch32
-rw-r--r--app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild (renamed from app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild)8
2 files changed, 38 insertions, 2 deletions
diff --git a/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch b/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch
new file mode 100644
index 000000000000..bdf4e616d486
--- /dev/null
+++ b/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch
@@ -0,0 +1,32 @@
+Fix implicit function declarations as they are not supported by clang16 with standard settings.
+
+Bug: https://bugs.gentoo.org/874717
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/callbacks.c
++++ b/callbacks.c
+@@ -33,6 +33,12 @@ gpointer create_progressbar_window (ChData *data);
+ gboolean update_progress(gpointer data);
+ gpointer async_lengthy_func(gpointer data);
+
++extern void scale_box_sensitive (ChData *data, gboolean sensitive);
++extern gshort move_earth_true (ChData *data);
++extern void get_and_set_options (ChData *data);
++extern gshort get_map_position (ChData *data);
++extern gboolean is_peters (ChData *data);
++extern void button_sensitive (ChData *data, gboolean sensitive);
+ /***************************************
+ Window Callbacks
+ ***************************************/
+--- a/sunlight.c
++++ b/sunlight.c
+@@ -19,6 +19,8 @@
+
+ #include "support.h"
+
++extern void change_wallpaper (ChData *data);
++
+ void initialize_variables (ChData *data){
+ data->var.gi_rd1 = 1;
+ data->var.gi_rd2 = 1;
diff --git a/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild b/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild
index e98885b1e722..223a18a74a99 100644
--- a/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild
+++ b/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs xdg
@@ -20,6 +20,10 @@ RDEPEND="
x11-libs/gtk+:3"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-function-declarations.patch
+)
+
src_compile() {
tc-export CC
default