summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-08-08 18:40:45 +0200
committerSebastian Pipping <sping@gentoo.org>2018-08-08 18:41:06 +0200
commitc1c7638727d755f9337fe0e2e033e43d2891aa0e (patch)
treece521ee5e35289af2f45205301f7906a5469c23b /app-text
parentdev-tex/biber: drop old (diff)
downloadgentoo-c1c7638727d755f9337fe0e2e033e43d2891aa0e.tar.gz
gentoo-c1c7638727d755f9337fe0e2e033e43d2891aa0e.tar.bz2
gentoo-c1c7638727d755f9337fe0e2e033e43d2891aa0e.zip
app-text/dvisvgm: 2.5
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-2.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 6e192f7a05a4..f5558761f7f2 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -5,3 +5,4 @@ DIST dvisvgm-2.3.4.tar.gz 2896641 BLAKE2B af434a418b5ebbb9acaccc4626b6278f3d0c76
DIST dvisvgm-2.3.5.tar.gz 2897194 BLAKE2B 7661d6f5ac097a6dc62cf873dee84ec47b55e4a87ec07597170d309ac4d8d06fa19e0e14dab3a6273f022c71112a00af4c0bf167e37687037f0c23d1ea74f20b SHA512 fcfbb8e53233383a61c0662951dc914d157eb64c89eb30f54afc36069d3ca6a347dae7e64febafee1ba9ea8d90b278da9cbe36b70169df48f12c42c077cd1038
DIST dvisvgm-2.4.2.tar.gz 2918538 BLAKE2B 373e2e6a017189dc130cc40f9abfd4601a1764400858860104e764757e93758a7d12c6b8125d684ba7a9d4bb21fe2820007852ea2e46f57cd3fe7d61d2a4d63b SHA512 9c2dbf088244898ce86a177d81cbf67bbae2df8703dce686016e2b455f6eea516751e84521f8097b82bd6a9e5b294043e3ee38cd470ff6ac1633a976828b99fc
DIST dvisvgm-2.4.tar.gz 2850942 BLAKE2B c1cdb4aed954bcb5704b83deba087403f366f0139b053b599029d103bd85306e58c7bffb1228d3ace02fd3be91eff002e6d1e45105bb8ccaa85945ba7bbf5210 SHA512 84f51fa8cbf0a32efe667321102b1705c613cc697d86d00df2e044cd97b1f390e1552af7da2891792ccef634507bbc6922f92f194f5acb7d05a48e268e708396
+DIST dvisvgm-2.5.tar.gz 2911331 BLAKE2B b9ee90f5e34784d690f6a9a80dd1cdc4ce516f1e50722a93a0ea6e03da4f60f1bb983fa8abd8e670b2719afbf3197e6483a5c401fa1d668f79569d6a21701be2 SHA512 a722abb94c93ed8f7a6a91730639b7471b37c8c215297efe2ee071ff31829911c49253f17ccbb01dcea578ff55f2b179d85a0d9d32f65ed34ab18455e844578e
diff --git a/app-text/dvisvgm/dvisvgm-2.5.ebuild b/app-text/dvisvgm/dvisvgm-2.5.ebuild
new file mode 100644
index 000000000000..4f200db18915
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="http://dvisvgm.bplaced.net/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+# Tests don't work from $WORKDIR: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+# TODO unbundle app-arch/brotli
+RDEPEND="virtual/tex-base
+ >=app-arch/brotli-1.0.5
+ app-text/ghostscript-gpl
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.6.5
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ dev-libs/kpathsea
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/xmlto
+ app-text/asciidoc
+ dev-libs/libxslt
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local myargs=(
+ --without-ttfautohint
+ )
+ econf "${myargs[@]}"
+}