summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2024-11-01 09:24:06 +0900
committerNaohiro Aota <naota@gentoo.org>2024-11-01 09:28:20 +0900
commit51797316863dd014ae5dc76e8694472c7b0879b6 (patch)
tree1fd56c95d649b7e7cf4ccab0b21f0c47a03d0900 /dev-build/cmake-fedora
parentdev-tcltk/tclxml: drop 3.2.7-r1 (diff)
downloadgentoo-51797316863dd014ae5dc76e8694472c7b0879b6.tar.gz
gentoo-51797316863dd014ae5dc76e8694472c7b0879b6.tar.bz2
gentoo-51797316863dd014ae5dc76e8694472c7b0879b6.zip
dev-build/cmake-fedora: fix sandbox issue
Add a patch to fix a sandbox issue. Closes: https://bugs.gentoo.org/604554 Signed-off-by: Naohiro Aota <naota@gentoo.org>
Diffstat (limited to 'dev-build/cmake-fedora')
-rw-r--r--dev-build/cmake-fedora/cmake-fedora-2.9.3.ebuild12
-rw-r--r--dev-build/cmake-fedora/files/cmake-fedora-2.9.3-no-release.patch23
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-build/cmake-fedora/cmake-fedora-2.9.3.ebuild b/dev-build/cmake-fedora/cmake-fedora-2.9.3.ebuild
index d106a4e095ed..cefa9f3b9c38 100644
--- a/dev-build/cmake-fedora/cmake-fedora-2.9.3.ebuild
+++ b/dev-build/cmake-fedora/cmake-fedora-2.9.3.ebuild
@@ -14,7 +14,9 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-# fails 1 of 7
+PATCHES=( "${FILESDIR}/${P}-no-release.patch" )
+
+# FIXME: Test running in the build directory, while it want a file in source directory.
RESTRICT="test"
src_prepare() {
@@ -25,3 +27,11 @@ src_prepare() {
cmake_src_prepare
}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_FEDORA_ENABLE_FEDORA_BUILD=0
+ -DMANAGE_DEPENDENCY_PACKAGE_EXISTS_CMD=true
+ )
+ cmake_src_configure
+}
diff --git a/dev-build/cmake-fedora/files/cmake-fedora-2.9.3-no-release.patch b/dev-build/cmake-fedora/files/cmake-fedora-2.9.3-no-release.patch
new file mode 100644
index 000000000000..3c7103585921
--- /dev/null
+++ b/dev-build/cmake-fedora/files/cmake-fedora-2.9.3-no-release.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/604554
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4a9d6af..16c3ca2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -137,16 +137,6 @@ ADD_DEPENDENCIES(tag_pre module-only)
+ # Release
+ #
+
+-INCLUDE(ManageRelease)
+-IF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
+- INCLUDE(ManageReleaseFedora)
+- RELEASE_FEDORA(fedora epel7 el6)
+- # "Off" Warning is displayed if mock is not installed.
+- MANAGE_RELEASE(tag_push release_fedora)
+-ELSE(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
+- MANAGE_RELEASE(tag_push)
+-ENDIF(CMAKE_FEDORA_ENABLE_FEDORA_BUILD)
+-
+ ####################################################################
+ # Test Suites.
+ #