summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2021-03-12 08:13:35 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2021-03-12 21:57:53 +0100
commit8be15d27df5ed20d59dcd698b0f485cc5310685f (patch)
tree2d3eac098251b825207e4603f28d3ea4392c65d1 /dev-db/libzdb
parentdev-util/systemtap: require dejagnu for FEATURES=test, bug #775566 (diff)
downloadgentoo-8be15d27df5ed20d59dcd698b0f485cc5310685f.tar.gz
gentoo-8be15d27df5ed20d59dcd698b0f485cc5310685f.tar.bz2
gentoo-8be15d27df5ed20d59dcd698b0f485cc5310685f.zip
dev-db/libzdb: version bump and re-add myself as maintainer
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Raschbacher <lordvan@gentoo.org>
Diffstat (limited to 'dev-db/libzdb')
-rw-r--r--dev-db/libzdb/Manifest1
-rw-r--r--dev-db/libzdb/libzdb-3.2.2.ebuild90
-rw-r--r--dev-db/libzdb/metadata.xml5
3 files changed, 95 insertions, 1 deletions
diff --git a/dev-db/libzdb/Manifest b/dev-db/libzdb/Manifest
index ccf0c0c60b68..dc4276ee3cc7 100644
--- a/dev-db/libzdb/Manifest
+++ b/dev-db/libzdb/Manifest
@@ -1 +1,2 @@
DIST libzdb-3.1.tar.gz 720162 BLAKE2B 2ad8ede7e2a1c0ee831ba546b7756d2688bcde83b537e812c12ab3d42d6bdc13526778ae68b61584a52569f0b42fbeb8462efe379821295d855f585ae3420df4 SHA512 7cf24ccf0f0a938955d8b54af2c6eca8a8f700737beafde9e824129f324511e06adbc11a3fdbd6ad6d9b902fdae6f7caab4e5c1c594d2211be314e3a24c697f3
+DIST libzdb-3.2.2.tar.gz 752292 BLAKE2B 449fe1cf9ac7196473ab45593d197ea9d02a91bb3b0efaaea91b3c95bb22de1ced68704835e542e092a9f507e8f2484a141e021721df84e818a18a36214f7c40 SHA512 1e732f8785322e0369de16a8100c9467e96ad1ca4eee31e8bfc349f4f17d4cc237a691addc060a66e1b46bcfeb99c3aed07b1d5dbe20e70fde4ffbf35dbea2eb
diff --git a/dev-db/libzdb/libzdb-3.2.2.ebuild b/dev-db/libzdb/libzdb-3.2.2.ebuild
new file mode 100644
index 000000000000..cc039a65aee6
--- /dev/null
+++ b/dev-db/libzdb/libzdb-3.2.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="https://www.tildeslash.com/libzdb/"
+SRC_URI="https://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc mysql postgres +sqlite ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RESTRICT=test
+
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+ # Fix detection of openssl 1.1
+ sed -i -e "s|SSL_library_init|SSL_CTX_new|" configure || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ # enable default hidden visibility
+ myconf="${myconf} --enable-protected"
+
+ if use sqlite; then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ default
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ docinto html
+ dodoc -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}
diff --git a/dev-db/libzdb/metadata.xml b/dev-db/libzdb/metadata.xml
index 7a38bb900964..ff82108a6c99 100644
--- a/dev-db/libzdb/metadata.xml
+++ b/dev-db/libzdb/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
</pkgmetadata>