summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hourglass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hourglass')
-rw-r--r--dev-haskell/hourglass/Manifest2
-rw-r--r--dev-haskell/hourglass/files/hourglass-0.2.6-ghc-7.10.patch14
-rw-r--r--dev-haskell/hourglass/hourglass-0.2.6.ebuild31
-rw-r--r--dev-haskell/hourglass/hourglass-0.2.9.ebuild30
-rw-r--r--dev-haskell/hourglass/metadata.xml16
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-haskell/hourglass/Manifest b/dev-haskell/hourglass/Manifest
new file mode 100644
index 000000000000..b3fbd8643db0
--- /dev/null
+++ b/dev-haskell/hourglass/Manifest
@@ -0,0 +1,2 @@
+DIST hourglass-0.2.6.tar.gz 23143 SHA256 a3a62b434c863848cb8ad97e0fb7e1712875a9a864115b8f3f324f934baf2e09 SHA512 f1c6157ffe218be04a6dfd4571a2e67ed5db0811e39f3374faa38bc1ab2e20e24f35f2a3e4b8439601249f7954bce032091f6733e051ea5aa4f5b20fc0aa4a1d WHIRLPOOL ecf99e010ae4ccd0a43d8ceb84847590e482ab68ed0dcf9af67df898caa7f2fd30be7a2c83d321494e9932ea2a334627ce572dd802d9c32dc53c7857b414bc81
+DIST hourglass-0.2.9.tar.gz 24919 SHA256 9b54f163a1ecad98fbd14cb9737c28001b2648106d98cbd68fb2f5cfed090af6 SHA512 ba6ee78b900139e8267a4bd9676abc2189e6c581225c5718c6f753515b1b7037ee4f8197f6910cc8ef769110234ec1cef7b3af0d1c6c7cef93bd87c81c7f57d4 WHIRLPOOL 803d95b868dc5a189d0d0c4e473d174e3b7849e5771e180b016f46b76062ffed23f158857255995be62fd9dd8386421cc35816eadcdadfb702e67507d911fe38
diff --git a/dev-haskell/hourglass/files/hourglass-0.2.6-ghc-7.10.patch b/dev-haskell/hourglass/files/hourglass-0.2.6-ghc-7.10.patch
new file mode 100644
index 000000000000..1756ba278d49
--- /dev/null
+++ b/dev-haskell/hourglass/files/hourglass-0.2.6-ghc-7.10.patch
@@ -0,0 +1,14 @@
+--- hourglass-0.2.6-orig/tests/Tests.hs 2014-10-19 20:25:15.000000000 +1100
++++ hourglass-0.2.6/tests/Tests.hs 2015-01-03 16:56:11.788832544 +1100
+@@ -25,7 +25,11 @@
+ import qualified Data.Time.Clock as T
+ import qualified Data.Time.Clock.POSIX as T
+ import qualified Data.Time.Format as T
++#if MIN_VERSION_time(1,5,0)
++import qualified System.Locale as T hiding (defaultTimeLocale)
++#else
+ import qualified System.Locale as T
++#endif
+
+ import qualified Control.Exception as E
+
diff --git a/dev-haskell/hourglass/hourglass-0.2.6.ebuild b/dev-haskell/hourglass/hourglass-0.2.6.ebuild
new file mode 100644
index 000000000000..f59380e9284e
--- /dev/null
+++ b/dev-haskell/hourglass/hourglass-0.2.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="simple performant time related library"
+HOMEPAGE="https://github.com/vincenthz/hs-hourglass"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/mtl
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+PATCHES=("${FILESDIR}/${PN}-0.2.6-ghc-7.10.patch")
diff --git a/dev-haskell/hourglass/hourglass-0.2.9.ebuild b/dev-haskell/hourglass/hourglass-0.2.9.ebuild
new file mode 100644
index 000000000000..66509c033893
--- /dev/null
+++ b/dev-haskell/hourglass/hourglass-0.2.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="simple performant time related library"
+HOMEPAGE="https://github.com/vincenthz/hs-hourglass"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/mtl
+ dev-haskell/old-locale
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
diff --git a/dev-haskell/hourglass/metadata.xml b/dev-haskell/hourglass/metadata.xml
new file mode 100644
index 000000000000..2b2d13d44158
--- /dev/null
+++ b/dev-haskell/hourglass/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple time library focusing on simple but powerful and performant API
+
+ The backbone of the library are the Timeable and Time type classes.
+
+ Each Timeable instances can be converted to type that has a Time instances,
+ and thus are different representations of current time.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-hourglass</remote-id>
+ </upstream>
+</pkgmetadata>