summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/gnu-hylafax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/gnu-hylafax')
-rw-r--r--dev-java/gnu-hylafax/Manifest1
-rw-r--r--dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch70
-rw-r--r--dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild53
-rw-r--r--dev-java/gnu-hylafax/metadata.xml8
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-java/gnu-hylafax/Manifest b/dev-java/gnu-hylafax/Manifest
new file mode 100644
index 000000000000..2f903d34d9af
--- /dev/null
+++ b/dev-java/gnu-hylafax/Manifest
@@ -0,0 +1 @@
+DIST gnu-hylafax-1.0.3-bin.tar.gz 1742697 SHA256 1e35853af20d74e1c3acbc460ef7fb04f76fc52be11ff0b560abe14b3c4f0a61 SHA512 7af66dac5a1b98eddc3d60aa439809f4e683a39a795ca50d0f99f92d4fb17704ab5c7528218be1f4698bca0749efd46c5ec3510e8a10a68b1b77faf1997dc4a2 WHIRLPOOL 2081d2238ca8ec5709ce7520547370b6a8431e33e33fb318612eb43cced6edfb1fc02836cca4bfc1d7c3edc24a3ea63bc53ac34cd573da436f10031c7f7b1ccf
diff --git a/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch b/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
new file mode 100644
index 000000000000..51bae74646ed
--- /dev/null
+++ b/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
@@ -0,0 +1,70 @@
+--- gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java.orig 2015-04-14 18:20:17.113435400 +0000
++++ gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java 2015-04-14 18:20:58.310438791 +0000
+@@ -32,7 +32,7 @@
+ import org.apache.commons.logging.Log;
+ import org.apache.commons.logging.LogFactory;
+
+-import EDU.oswego.cs.dl.util.concurrent.LinkedQueue;
++import java.util.concurrent.ConcurrentLinkedQueue;
+
+ public class ClientPool implements gnu.hylafax.ClientPool {
+
+@@ -42,7 +42,7 @@
+
+ private HashMap clientMap;
+
+- private LinkedQueue clients;
++ private ConcurrentLinkedQueue clients;
+
+ private ClientPoolConfiguration configuration;
+
+@@ -66,7 +66,7 @@
+
+ public ClientPool(ClientPoolConfiguration configuration) {
+ this.configuration = configuration;
+- clients = new LinkedQueue();
++ clients = new ConcurrentLinkedQueue();
+ clientMap = new HashMap();
+ workingClients = new HashSet();
+ workingClientsToClose = new HashSet();
+@@ -163,8 +163,7 @@
+ blocked = true;
+ }
+
+- client = (PooledClient) clients.poll(getConfiguration()
+- .getRetryInterval());
++ client = (PooledClient) clients.poll();
+ if (client == null)
+ log.warn("No Clients Available.");
+ else if (!clientAdded)
+@@ -172,10 +171,10 @@
+ }
+
+ } else {
+- client = (PooledClient) clients.take();
++ client = (PooledClient) clients.poll();
+ }
+ }
+- } catch (InterruptedException e) {
++ } catch (Exception e) {
+ throw new ClientPoolException(
+ "Interrupted Thread and No Free Connection Available.");
+ }
+@@ -294,7 +293,7 @@
+ destroyClient(client);
+ addClient();
+ } else {
+- clients.put(client);
++ clients.offer(client);
+ size++;
+ }
+ }
+@@ -306,7 +305,7 @@
+
+ log.debug("Released Client.");
+
+- } catch (InterruptedException e) {
++ } catch (Exception e) {
+ log.warn("Was Interrupted.", e);
+ destroyClient(client);
+ } finally {
diff --git a/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild b/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..04bfbb815c71
--- /dev/null
+++ b/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java API designed to implement the client protocol portion of the hfaxd server"
+HOMEPAGE="http://gnu-hylafax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}-bin.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/commons-logging:0
+ dev-java/commons-cli:1
+ dev-java/oracle-javamail:0
+ dev-java/java-getopt:1
+ dev-java/log4j:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+JAVA_GENTOO_CLASSPATH="
+ commons-logging
+ commons-cli-1
+ oracle-javamail
+ java-getopt-1
+ log4j"
+
+S="${WORKDIR}/${P}"
+
+# bug 546502
+PATCHES=(
+ "${FILESDIR}"/"${P}"-ClientPool.patch
+)
+
+java_prepare() {
+ rm -rv "${S}"/lib || die
+ find -name "pom.xml" -delete || die
+
+ # tarball contains the same sources in gnu-.../sources and gnu-.../main/
+ rm -r gnu-hylafax-*/sources || die
+
+ epatch ${PATCHES[@]}
+
+}
diff --git a/dev-java/gnu-hylafax/metadata.xml b/dev-java/gnu-hylafax/metadata.xml
new file mode 100644
index 000000000000..00c3849387b1
--- /dev/null
+++ b/dev-java/gnu-hylafax/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">gnu-hylafax</remote-id>
+ </upstream>
+</pkgmetadata>