summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-01 04:53:25 +0100
committerSam James <sam@gentoo.org>2023-06-01 04:53:25 +0100
commit79e28ab5829ff1f4bad86b0bb60719eaccdae052 (patch)
treeb07ef160beb69be58b47a364cb6b01a4c8b8477f /dev-libs/capnproto/capnproto-0.10.4-r1.ebuild
parentsys-libs/libxcrypt: add 4.4.34 (diff)
downloadgentoo-79e28ab5829ff1f4bad86b0bb60719eaccdae052.tar.gz
gentoo-79e28ab5829ff1f4bad86b0bb60719eaccdae052.tar.bz2
gentoo-79e28ab5829ff1f4bad86b0bb60719eaccdae052.zip
dev-libs/capnproto: fix subslot
Just use ${PV} as, like protobuf, this seems to break ABI a lot. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.10.4-r1.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.10.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild b/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild
new file mode 100644
index 000000000000..30c2d9f10ffc
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:= )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ append-atomic-flags
+ if [[ ${LIBS} == *atomic* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}