summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:18:16 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:18:16 +0100
commitab66ee952acca26987c5455d06d6cc403ee94c68 (patch)
treed7b7093e8e281f4ef28c0410582d958aaf56882e /dev-libs/eb
parentdev-libs/dotconf: disable static libs (diff)
downloadgentoo-ab66ee952acca26987c5455d06d6cc403ee94c68.tar.gz
gentoo-ab66ee952acca26987c5455d06d6cc403ee94c68.tar.bz2
gentoo-ab66ee952acca26987c5455d06d6cc403ee94c68.zip
dev-libs/eb: disable static libs
Closes: https://bugs.gentoo.org/726496 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/eb')
-rw-r--r--dev-libs/eb/eb-4.4.1-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/eb/eb-4.4.1-r1.ebuild b/dev-libs/eb/eb-4.4.1-r1.ebuild
index 254ea4b8e9b2..fc59b4ffde58 100644
--- a/dev-libs/eb/eb-4.4.1-r1.ebuild
+++ b/dev-libs/eb/eb-4.4.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="EB is a C library and utilities for accessing CD-ROM books"
HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/eb/"
@@ -14,12 +14,9 @@ IUSE="ipv6 nls threads"
RDEPEND="
sys-libs/zlib
- nls? ( virtual/libintl )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
DOCS=( AUTHORS ChangeLog{,.0,.1,.2} NEWS README )
@@ -28,5 +25,11 @@ src_configure() {
$(use_enable ipv6) \
$(use_enable nls) \
$(use_enable threads pthread) \
- --with-pkgdocdir=/usr/share/doc/${PF}/html
+ --with-pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}