summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 01:14:29 +0000
committerSam James <sam@gentoo.org>2021-03-10 01:14:52 +0000
commit3e4b6af2825b3d18187474d53890a0ccba72bce6 (patch)
tree1f044c07b10e524d5184e0f267d5f262597611b1 /dev-libs/geoip/geoip-1.6.12.ebuild
parentdev-libs/geoip: drop 1.6.9-r1, 1.6.10, 1.6.11 (diff)
downloadgentoo-3e4b6af2825b3d18187474d53890a0ccba72bce6.tar.gz
gentoo-3e4b6af2825b3d18187474d53890a0ccba72bce6.tar.bz2
gentoo-3e4b6af2825b3d18187474d53890a0ccba72bce6.zip
dev-libs/geoip: update EAPI 6 -> 7, fix invalid ROOT usage
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/geoip/geoip-1.6.12.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.6.12.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/dev-libs/geoip/geoip-1.6.12.ebuild b/dev-libs/geoip/geoip-1.6.12.ebuild
index 2f5ee8e5606d..8d3acd5e9c69 100644
--- a/dev-libs/geoip/geoip-1.6.12.ebuild
+++ b/dev-libs/geoip/geoip-1.6.12.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="GeoIP Legacy C API"
HOMEPAGE="https://github.com/maxmind/geoip-api-c"
-SRC_URI="
- https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
+SRC_URI="https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-api-c-${PV}"
# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
LICENSE="LGPL-2.1 GPL-2 MaxMind2"
@@ -17,24 +17,17 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd
IUSE="static-libs"
RESTRICT="test"
-DEPEND="
- net-misc/wget
-"
-RDEPEND="
- ${DEPEND}
-"
-
-S="${WORKDIR}/${PN}-api-c-${PV}"
+DEPEND="net-misc/wget"
+RDEPEND="${DEPEND}"
src_prepare() {
default
-
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
- sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r6.sh > geoipupdate.sh || die
+ sed -e "s|@PREFIX@|${EPREFIX}|g" "${FILESDIR}"/geoipupdate-r6.sh > geoipupdate.sh || die
}
src_install() {
@@ -42,7 +35,7 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS.md README*
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
keepdir /usr/share/GeoIP
@@ -52,6 +45,6 @@ src_install() {
pkg_postinst() {
ewarn "WARNING: Databases are no longer installed by this ebuild."
elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
- elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
+ elog "net-misc/geoipupdate) to populate ${EROOT}/usr/share/GeoIP/"
elog "with geo-located IP address databases."
}