summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-05 07:25:22 +0100
committerSam James <sam@gentoo.org>2021-10-05 07:26:34 +0100
commit548b44240beafd530c26a2e79a386b8f3c1ccd02 (patch)
treefc88c6287070f943e40bc60ec983cb8518e1b04e /dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
parentdev-ruby/text: add ruby30 (diff)
downloadgentoo-548b44240beafd530c26a2e79a386b8f3c1ccd02.tar.gz
gentoo-548b44240beafd530c26a2e79a386b8f3c1ccd02.tar.bz2
gentoo-548b44240beafd530c26a2e79a386b8f3c1ccd02.zip
dev-ml/ppx_optcomp: add 0.14.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild')
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
new file mode 100644
index 000000000000..d01ce62cd244
--- /dev/null
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Optional compilation for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_optcomp"
+SRC_URI="https://github.com/janestreet/ppx_optcomp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"