summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-26 21:50:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-26 21:50:35 +0200
commit5a803b8ad117e31bf622f7858422805742b6c1e4 (patch)
treeabcc0f3cf8e9f002ebae083b902e1012dc1a6e25 /dev-python/argcomplete
parentwww-client/chromium: keep icu if compiling with libcxx (diff)
downloadgentoo-5a803b8ad117e31bf622f7858422805742b6c1e4.tar.gz
gentoo-5a803b8ad117e31bf622f7858422805742b6c1e4.tar.bz2
gentoo-5a803b8ad117e31bf622f7858422805742b6c1e4.zip
dev-python/argcomplete: Require non-ancient dev-python/pip for tests
Tests fail with pip-9, so require >=19. Sadly, this means rekeywording. Closes: https://bugs.gentoo.org/709944 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete')
-rw-r--r--dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..47957f564adc
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/importlib_metadata-2[${PYTHON_USEDEP}]
+ ' -2 python3_{5,6,7} pypy3)"
+# pip is called as an external tool
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )"
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}