summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-02-14 14:14:46 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-02-14 14:15:25 -0500
commit548c1482c748845e3dac7351d2e622fdce5727f4 (patch)
tree1161af97a3c383ec19d719c282f63ba3d81e04f9 /dev-python/autobahn
parentapp-mobilephone/heimdall: EAPI-7, cmake.eclass, IUSE=qt5->gui (diff)
downloadgentoo-548c1482c748845e3dac7351d2e622fdce5727f4.tar.gz
gentoo-548c1482c748845e3dac7351d2e622fdce5727f4.tar.bz2
gentoo-548c1482c748845e3dac7351d2e622fdce5727f4.zip
dev-python/autobahn: Fix tinderbox sandbox issue
Closes: https://bugs.gentoo.org/753338 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/autobahn-21.2.1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/autobahn/autobahn-21.2.1.ebuild b/dev-python/autobahn/autobahn-21.2.1.ebuild
index 8cc01e514d37..78281c5cf7a4 100644
--- a/dev-python/autobahn/autobahn-21.2.1.ebuild
+++ b/dev-python/autobahn/autobahn-21.2.1.ebuild
@@ -72,6 +72,11 @@ python_prepare_all() {
# remove xbr components
export AUTOBAHN_STRIP_XBR="True"
fi
+ # remove twisted plugin cache regen in setup.py
+ # to fix tinderbox sandbox issue
+ sed -e 's/# regenerate Twisted plugin cache/# DO NOT regenerate Twisted plugin cache in Gentoo\nexit()/' \
+ -i setup.py || die
+
distutils-r1_python_prepare_all
}
@@ -89,13 +94,6 @@ python_test() {
rm -r .pytest_cache || die
}
-python_install_all() {
- distutils-r1_python_install_all
-
- # delete the dropin.cache so we don't have collisions if it exists
- rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache > /dev/null
-}
-
pkg_postinst() {
python_foreach_impl twisted-regen-cache || die
}