summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 13:13:08 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 13:58:10 +0200
commitcbe5d9d4b6a9c69d027b1185afa2f9fd01eb3470 (patch)
tree871ab03282e9b15ad189c06ffbf6dd96f69eb740 /dev-python/cherrypy
parentdev-python/txrequests: Clean old versions up (diff)
downloadgentoo-cbe5d9d4b6a9c69d027b1185afa2f9fd01eb3470.tar.gz
gentoo-cbe5d9d4b6a9c69d027b1185afa2f9fd01eb3470.tar.bz2
gentoo-cbe5d9d4b6a9c69d027b1185afa2f9fd01eb3470.zip
dev-python/cherrypy: Clean old versions up
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest2
-rw-r--r--dev-python/cherrypy/cherrypy-3.3.0.ebuild52
-rw-r--r--dev-python/cherrypy/cherrypy-3.7.0.ebuild51
-rw-r--r--dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch20
4 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index b8caa00fb9c0..03e4f61bd9df 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,3 +1 @@
-DIST CherryPy-3.3.0.tar.gz 429204 SHA256 f8829bf1b4f613833b690b33b2fd00b1da4ef98df3c70240f78ee91b70f4a5a2 SHA512 605d1ca5694cd8c5237f2115ef2ca39d7290b90c82b91c3699cfb59ad346c3506a1b78ad0502f89de43f8711d01afbbc2eb82f00f86ffbc0fcd63c1def88f0a4 WHIRLPOOL 406c735ae3b5f52408bab6fdde32684caeeb2092b4b0124b12cd43923beb1b11e899069ed48d395839bbb55e202e748ad2cb4e0c626ed29a0d2ff0bfef8aae5b
-DIST CherryPy-3.7.0.tar.gz 433083 SHA256 2d19b9a99dc70c01d7ac58b5c2a0c6f6c0e12620e6f5dc1f556f6c1cdfd90ef8 SHA512 e8ad7eba4074aba65b1b7368cae90c1a5bd5f58217e05fe96a82e591d1e4e544555b815e19019373574f8545a80a52884e4015f6b39512b2f6fa4dc5e80f1253 WHIRLPOOL a2a8127a2ea3a2b497b18751c7ef10e61902ba8b909695c4afc926a31c8715ab1c30d5e0b865de90e931c40fed5385bb0c9902d61f8a7bc39feaf5b50303b9e6
DIST CherryPy-3.8.0.tar.gz 433711 SHA256 ffcdb43667d4098247efaf8c82dd36d3dd4f8e5dc768ef5e90b480899e523bea SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2 WHIRLPOOL 9e484fb5589e219108c48281f34bbe64d4767796a391dfb7f194f57dda89774d4517a6acd032fb492879a7bae2d0373e843e4b8aad53bf7b606b1b60dc2bfe56
diff --git a/dev-python/cherrypy/cherrypy-3.3.0.ebuild b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
deleted file mode 100644
index 4f2448cbef88..000000000000
--- a/dev-python/cherrypy/cherrypy-3.3.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ https://pypi.python.org/pypi/CherryPy"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}/${PN}-3.3.0-test_config.patch" )
-
-python_prepare_all() {
- # Prevent interactive failures (hangs) in the test suite
- sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # suite requires current latest nose-1.3.3
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308
- # https://bitbucket.org/cherrypy/cherrypy/issue/1306
- local exclude=(
- -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
- -e test_2_File_Concurrency -e test_0_Session -e testStatic
- )
-
- # This really doesn't sit well with multiprocessing
- # The issue 1306 tells us some tests are subject to the deleterious effects of
- # the 'race condition'. Both the issues are unresolved / open
- if [[ "${EPYTHON}" == pypy ]]; then
- nosetests "${exclude[@]}" -I test_logging.py < /dev/tty || die "Testing failed with${EPYTHON}"
- else
- nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
- fi
-}
diff --git a/dev-python/cherrypy/cherrypy-3.7.0.ebuild b/dev-python/cherrypy/cherrypy-3.7.0.ebuild
deleted file mode 100644
index 5ed8975de21c..000000000000
--- a/dev-python/cherrypy/cherrypy-3.7.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ https://pypi.python.org/pypi/CherryPy"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-
-# testsuite predominantly connects to the network
-RESTRICT="test"
-
-python_prepare_all() {
- # Prevent interactive failures (hangs) in the test suite
- sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # suite requires current latest nose-1.3.3
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308
- # https://bitbucket.org/cherrypy/cherrypy/issue/1306
- local exclude=(
- -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
- -e test_2_File_Concurrency -e test_0_Session -e testStatic
- )
-
- # This really doesn't sit well with multiprocessing
- # The issue 1306 tells us some tests are subject to the deleterious effects of
- # the 'race condition'. Both the issues are unresolved / open
-# if [[ "${EPYTHON}" == pypy ]]; then
- nosetests "${exclude[@]}" -I test_logging.py || die "Testing failed with ${EPYTHON}"
-# else
-# nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
-# fi
-}
diff --git a/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch b/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch
deleted file mode 100644
index 55c719564621..000000000000
--- a/dev-python/cherrypy/files/cherrypy-3.3.0-test_config.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-# HG changeset patch
-# User Mike Gilbert <floppym@gentoo.org>
-# Date 1399130996 14400
-# Sat May 03 11:29:56 2014 -0400
-# Node ID f8f63e119bd85b16bdee9b95195aba60d5fbca27
-# Parent 60c8bb0cd34632becb758a063032e76c13dc3425
-Remove unicode literal to avoid syntax error in python3.2
-
-diff --git a/cherrypy/test/test_config.py b/cherrypy/test/test_config.py
---- a/cherrypy/test/test_config.py
-+++ b/cherrypy/test/test_config.py
-@@ -206,7 +206,7 @@
-
- if not compat.py3k:
- self.getPage("/repr?key=thing3")
-- self.assertBody(repr(u'test'))
-+ self.assertBody(repr(unicode('test')))
-
- self.getPage("/repr?key=complex")
- self.assertBody("(3+2j)")