summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-02 10:03:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-02 10:16:20 +0100
commit4c418bbe5968b844a5b4f870fa42ec8265b4eb15 (patch)
treecf18372d4c7eeb62391ef225408205795df5e89c /dev-python/flufl-lock
parentdev-python/hypothesis: Bump to 5.43.8 (diff)
downloadgentoo-4c418bbe5968b844a5b4f870fa42ec8265b4eb15.tar.gz
gentoo-4c418bbe5968b844a5b4f870fa42ec8265b4eb15.tar.bz2
gentoo-4c418bbe5968b844a5b4f870fa42ec8265b4eb15.zip
dev-python/flufl-lock: Bump to 5.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flufl-lock')
-rw-r--r--dev-python/flufl-lock/Manifest1
-rw-r--r--dev-python/flufl-lock/flufl-lock-5.0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flufl-lock/Manifest b/dev-python/flufl-lock/Manifest
index 76f79e11cd35..5110585fe579 100644
--- a/dev-python/flufl-lock/Manifest
+++ b/dev-python/flufl-lock/Manifest
@@ -1 +1,2 @@
DIST flufl-lock-5.0.1.tar.gz 27788 BLAKE2B 2651898e881719f24bc61e14f697877ca39f2747fadf52de1a5fc917b26e23001df5f0a4ea2e48271da69198e1a1336e69cc0167a4f46fddd21f464b355fa4ca SHA512 f937fb6c7f7bef2b85674225f83f3162f34db3fe2df3d9a896f772c4489c3e0611361e3d1d9efda7727112d780f31022d3045d3a3b8e78e9412aca2f2418ca24
+DIST flufl.lock-5.0.4.tar.gz 29486 BLAKE2B 3fc6c3bfdac3c877c82f9f56e739342604be9f855a42a99bd06e5fb89fe8b3bc4cabd2e357e8e0992f7aa3f5ec7ea4a18e1f59a05beeeed7074a72440d3f6b9b SHA512 c08d8115c836f7523887d86539e9f11a2007913936fd8a4a116a610b648adf289fb086e8904b2163a6af7449e92a6edf9fad09fb770a34473768ffc4d8eb146e
diff --git a/dev-python/flufl-lock/flufl-lock-5.0.4.ebuild b/dev-python/flufl-lock/flufl-lock-5.0.4.ebuild
new file mode 100644
index 000000000000..57e4a8b7e444
--- /dev/null
+++ b/dev-python/flufl-lock/flufl-lock-5.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.lock"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=flufl::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}