summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-20 05:34:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-20 05:34:00 +0100
commit324aa23cac7f3f5a1dbda702198fe0b7734bfe5b (patch)
treed14c9c74b241034f4fbd86836980f1f4e3845599 /dev-python/imageio
parentdev-python/pydevd: Stabilize 2.7.0 hppa, #821763 (diff)
downloadgentoo-324aa23cac7f3f5a1dbda702198fe0b7734bfe5b.tar.gz
gentoo-324aa23cac7f3f5a1dbda702198fe0b7734bfe5b.tar.bz2
gentoo-324aa23cac7f3f5a1dbda702198fe0b7734bfe5b.zip
dev-python/imageio: Bump to 2.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.11.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index b4377f0e146c..97f9c55c1381 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,3 +1,4 @@
DIST imageio-2.10.4.gh.tar.gz 335495 BLAKE2B 66f8662953d7023557d4fc98b9cf2cfa00346a14286b72dd1b3abf618ee6da36da341c4a57116197e0f138424ef01050cc9176c6afcf277796aa61199e5a1530 SHA512 562bb0d7c8e627e491910f997947a4ffe967ed6dcf3d281b07145f9c8148ca0f2d9775bc89c9024ebc9bfa54f03a60aadc30a84827c050f18dbb23286ac18b96
DIST imageio-2.10.5.gh.tar.gz 335546 BLAKE2B 1bfd418bb59f217c2108be9aedf35d1b6326d29d476ac6648041b38efa44a2220212f170cae90005e027006adfe55178dee699a1e4b37b7e948863c61432afe8 SHA512 2a058e8ce7e2ad650bea05573d249c1c06326dd1ed0f47517c3a0095a2e03fa2b90ffa5f8aae535e937b8b9fd8153ccb13267773183e45639205faddab08348a
DIST imageio-2.11.0.gh.tar.gz 339057 BLAKE2B 6dd5661866135b472a062b57b424e8ff044510488b1ccd291552f979263f2f03d3feb00ad9ab035249a2966711e804a95ff7e8f174a1f0773445782365744b6c SHA512 b42f05eabcbee4fb4bb66793cca04137b4db2695269c204b2fec43527ab6a1d9e29c688061ee53c28454b64e09343d69cc931867c5aca01d47145bd734348629
+DIST imageio-2.11.1.gh.tar.gz 339241 BLAKE2B b197c946fe34e504979c9fe7e69179211bf72d986105175419c304b95628c02d3dae2e5e7b13902493cb6a7538bc3e5976590e25a35165c857623b62635b79b3 SHA512 cf33d0c96a08f29ed761e811922a31a97c36aef48022708132d5282bf5c87bb3ef67a80a98e01f57489fd4a261955e4ca231c67dfc69f5865c47a5b1f317d137
diff --git a/dev-python/imageio/imageio-2.11.1.ebuild b/dev-python/imageio/imageio-2.11.1.ebuild
new file mode 100644
index 000000000000..cd5928118230
--- /dev/null
+++ b/dev-python/imageio/imageio-2.11.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+)
+
+EPYTEST_IGNORE=(
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+ # Needs tifffile
+ tests/test_tifffile.py
+)