summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:20:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:36 +0100
commita90def0c00a973df10a348eb0b1f440ee8d8504e (patch)
tree9f7f88bb41b1ed2192bc5ddad6770f29944594c3 /dev-python/pyFFTW
parentdev-python/attrs: Bump to 21.3.0 (diff)
downloadgentoo-a90def0c00a973df10a348eb0b1f440ee8d8504e.tar.gz
gentoo-a90def0c00a973df10a348eb0b1f440ee8d8504e.tar.bz2
gentoo-a90def0c00a973df10a348eb0b1f440ee8d8504e.zip
dev-python/pyFFTW: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyFFTW')
-rw-r--r--dev-python/pyFFTW/Manifest1
-rw-r--r--dev-python/pyFFTW/pyFFTW-0.13.0.ebuild42
-rw-r--r--dev-python/pyFFTW/pyFFTW-9999.ebuild16
3 files changed, 51 insertions, 8 deletions
diff --git a/dev-python/pyFFTW/Manifest b/dev-python/pyFFTW/Manifest
index 94156daae57f..7857d7f47f2b 100644
--- a/dev-python/pyFFTW/Manifest
+++ b/dev-python/pyFFTW/Manifest
@@ -1 +1,2 @@
DIST pyFFTW-0.12.0.tar.gz 147372 BLAKE2B 1ea1f1f8de6759c42781a535b30d7119c0cb02dffea3abfe4130a97c465e000aa9b3064a219718569552304513a77ac51aa309f1be29f9eecae25c63cce70c6c SHA512 e4d7258d5c053b5367d8c4f1892eba8e595f9d540c1c3e6caf61e0c113d598ba872b5e72a21edace66be70d9ad75c599e4b1fbc692e0015c3c1ae35e9a7ba599
+DIST pyFFTW-0.13.0.tar.gz 158660 BLAKE2B c54096f0814625d49832094a6d823c6d258801a0831b07846993da97a713238a5df5b59beddc38b7e940685403178b2f3100f5713334fc9861757420bc87303a SHA512 1d4c69cc19dd00f2433037f25ea90335544403b542c0c5ca00cb055e0fde076ec9e00990f02da2385466be171ed8c910a5ce06a7cfa5efbc6544b2383bbce599
diff --git a/dev-python/pyFFTW/pyFFTW-0.13.0.ebuild b/dev-python/pyFFTW/pyFFTW-0.13.0.ebuild
new file mode 100644
index 000000000000..db7b32f540a5
--- /dev/null
+++ b/dev-python/pyFFTW/pyFFTW-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pythonic python wrapper around FFTW"
+HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
+
+LICENSE="BSD"
+SLOT="0"
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0=[threads]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/dask-1.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cp -r -l -n tests/ "${BUILD_DIR}/lib" || die
+ cd "${BUILD_DIR}/lib" || die
+ eunittest
+ rm -r tests/ || die
+}
diff --git a/dev-python/pyFFTW/pyFFTW-9999.ebuild b/dev-python/pyFFTW/pyFFTW-9999.ebuild
index 8ec87a34fe67..db7b32f540a5 100644
--- a/dev-python/pyFFTW/pyFFTW-9999.ebuild
+++ b/dev-python/pyFFTW/pyFFTW-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A pythonic python wrapper around FFTW"
@@ -20,23 +20,23 @@ else
fi
DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
>=sci-libs/fftw-3.3:3.0=[threads]
"
RDEPEND="${DEPEND}"
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
test? (
- dev-python/dask[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/dask-1.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2.0[${PYTHON_USEDEP}]
)
"
distutils_enable_tests unittest
python_test() {
- cp -r -l -n test/ "${BUILD_DIR}/lib" || die
+ cp -r -l -n tests/ "${BUILD_DIR}/lib" || die
cd "${BUILD_DIR}/lib" || die
eunittest
- rm -r test/ || die
+ rm -r tests/ || die
}