summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-29 06:51:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-29 07:51:32 +0100
commitb87dbb48e217d1ebd0c4e6d55f6b69e7c8e44529 (patch)
treeaeb00f95da48fd1c709ecc979606154ac97c1607 /dev-python/pytest-httpx
parentdev-python/yarl: Bump to 1.17.0 (diff)
downloadgentoo-b87dbb48e217d1ebd0c4e6d55f6b69e7c8e44529.tar.gz
gentoo-b87dbb48e217d1ebd0c4e6d55f6b69e7c8e44529.tar.bz2
gentoo-b87dbb48e217d1ebd0c4e6d55f6b69e7c8e44529.zip
dev-python/pytest-httpx: Bump to 0.33.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.33.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index e610754d9615..b3aef8c8da1f 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest_httpx-0.32.0.tar.gz 43824 BLAKE2B d373703f5614e7d3d75631bef7c316ae0e5e1963eb1ffdff3fd6a10c65e095e44d1bf09eb81dd9b90492a8e44f19d650875f7302d4843854622df620eb146bde SHA512 fed3b83e4b3162f1500f3a591650aca5a0c09a1a640c5718ae00d4a3e3e9df8b6a90ec4cc1a1e77b6d2be7de80dec8fe69d8fb601de164c7ad84322acc1eb7d0
+DIST pytest_httpx-0.33.0.tar.gz 51708 BLAKE2B c4b4a5bc41c44b982dcfe81f09ec4b3ee1eeed9cdc52cea6889988692bfb312eb7c4105cdcd60fadbbf0602236e2e5baf3c1a448248189214c0ec77cde8a3ea4 SHA512 96e3b5e0264f61644ed22fc809f35d0b2b255aa2ba75a5bf33d165c35276f2b731689b70cfbab5b5c901b1be4ff59c4b21704f8b15453582a6095611380830c8
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.33.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.33.0.ebuild
new file mode 100644
index 000000000000..609a6666899b
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.33.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest