summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ntlm-http
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ntlm-http')
-rw-r--r--dev-ruby/ntlm-http/Manifest1
-rw-r--r--dev-ruby/ntlm-http/files/ntlm-http-0.1.1+ruby-1.9.patch24
-rw-r--r--dev-ruby/ntlm-http/metadata.xml5
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild36
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild37
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-ruby/ntlm-http/Manifest b/dev-ruby/ntlm-http/Manifest
new file mode 100644
index 000000000000..5bb46da80012
--- /dev/null
+++ b/dev-ruby/ntlm-http/Manifest
@@ -0,0 +1 @@
+DIST ntlm-http-0.1.1.gem 13824 SHA256 66b463ce8a9bf720045786df26cfec4a800f91fb7847af83f2fc209e9d0ba07b SHA512 1d2868582a194fb3a3dcb48a7dfb031014e51a93d57afb83aaef98be8e57789506b71e6440770ca7bc48979d9dd730f398d01d554d6d0575ff01046a227c7669 WHIRLPOOL 646f6901c1d066a0c893ee0c48813e12512896f2d2f6c330da0209e6a5b821cf567d2a038ffe54ee7f9cacb54c6406a537033271d6777bb6ddb442d0bcb339e7
diff --git a/dev-ruby/ntlm-http/files/ntlm-http-0.1.1+ruby-1.9.patch b/dev-ruby/ntlm-http/files/ntlm-http-0.1.1+ruby-1.9.patch
new file mode 100644
index 000000000000..b5e35a7210c5
--- /dev/null
+++ b/dev-ruby/ntlm-http/files/ntlm-http-0.1.1+ruby-1.9.patch
@@ -0,0 +1,24 @@
+Index: ntlm-http-0.1.1/lib/net/ntlm_http.rb
+===================================================================
+--- ntlm-http-0.1.1.orig/lib/net/ntlm_http.rb
++++ ntlm-http-0.1.1/lib/net/ntlm_http.rb
+@@ -45,6 +45,7 @@
+ require 'base64'
+ require 'openssl'
+ require 'openssl/digest'
++require 'kconv'
+
+ module Net #:nodoc:
+ module NTLM
+Index: ntlm-http-0.1.1/lib/net/ntlm.rb
+===================================================================
+--- ntlm-http-0.1.1.orig/lib/net/ntlm.rb
++++ ntlm-http-0.1.1/lib/net/ntlm.rb
+@@ -45,6 +45,7 @@
+ require 'base64'
+ require 'openssl'
+ require 'openssl/digest'
++require 'kconv'
+
+ module Net #:nodoc:
+ module NTLM
diff --git a/dev-ruby/ntlm-http/metadata.xml b/dev-ruby/ntlm-http/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/ntlm-http/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..4817085dd005
--- /dev/null
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby/NTLM HTTP provides NTLM authentication over http"
+HOMEPAGE="http://www.mindflowsolutions.net/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+all_ruby_prepare() {
+ find . -name '*.rb' -exec sed -i -e 's:\r$::' {} +
+
+ # We can't use RUBY_PATCHES for this because we need first to convert the files
+ epatch "${FILESDIR}"/${P}+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/*_test.rb
+}
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..e12a2b1fc454
--- /dev/null
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby → tests fail _badly_
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby/NTLM HTTP provides NTLM authentication over http"
+HOMEPAGE="http://www.mindflowsolutions.net/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+all_ruby_prepare() {
+ find . -name '*.rb' -exec sed -i -e 's:\r$::' {} +
+
+ # We can't use RUBY_PATCHES for this because we need first to convert the files
+ epatch "${FILESDIR}"/${P}+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/*_test.rb
+}