summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-14 09:09:49 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-14 09:10:17 +0100
commit84e85895f39ae7e213c15c020085d5c6ea9db489 (patch)
tree8c999d2789862195d314ee4a10eee2963aabf282 /dev-ruby
parentwww-apps/nanoc: add 4.12.3 (diff)
downloadgentoo-84e85895f39ae7e213c15c020085d5c6ea9db489.tar.gz
gentoo-84e85895f39ae7e213c15c020085d5c6ea9db489.tar.bz2
gentoo-84e85895f39ae7e213c15c020085d5c6ea9db489.zip
dev-ruby/permutation: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/permutation/permutation-0.1.8-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/permutation/permutation-0.1.8-r2.ebuild b/dev-ruby/permutation/permutation-0.1.8-r2.ebuild
new file mode 100644
index 000000000000..9eeb47e6729a
--- /dev/null
+++ b/dev-ruby/permutation/permutation-0.1.8-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Library performing operations with permutations of sequences (strings, arrays)"
+HOMEPAGE="https://flori.github.com/permutation"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die
+}