summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-12-13 20:45:05 -0600
committerJohn Helmert III <ajak@gentoo.org>2022-12-13 20:58:40 -0600
commit164714be98f6e085a4bb77370da61b07573397a1 (patch)
tree411b50f7a423855d6a3263e0ce806f6bd7947eee /gui-apps/wofi
parentx11-base/xorg-server: Version bump to 21.1.5 (diff)
downloadgentoo-164714be98f6e085a4bb77370da61b07573397a1.tar.gz
gentoo-164714be98f6e085a4bb77370da61b07573397a1.tar.bz2
gentoo-164714be98f6e085a4bb77370da61b07573397a1.zip
gui-apps/wofi: new package, add 1.3, 9999
Closes: https://bugs.gentoo.org/711876 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'gui-apps/wofi')
-rw-r--r--gui-apps/wofi/Manifest1
-rw-r--r--gui-apps/wofi/files/wofi-1.3-no-hg-identify.patch31
-rw-r--r--gui-apps/wofi/metadata.xml13
-rw-r--r--gui-apps/wofi/wofi-1.3.ebuild28
-rw-r--r--gui-apps/wofi/wofi-9999.ebuild28
5 files changed, 101 insertions, 0 deletions
diff --git a/gui-apps/wofi/Manifest b/gui-apps/wofi/Manifest
new file mode 100644
index 000000000000..cf96341ed942
--- /dev/null
+++ b/gui-apps/wofi/Manifest
@@ -0,0 +1 @@
+DIST wofi-1.3.tar.gz 77317 BLAKE2B 0282921c0605ee251701a33d9137f027c87ecd33f9c97b054ac9f0deeffbbcd73232e5a96e9be012eeeb298d84e257ca4752038315f92afc653573dd075179c0 SHA512 90a1674bcf5365aa47d6a8b987e7507539da5652f045b18446c073913399a6e46ffd50a6a83212d521c349840912ec9edab0c69dd565e2a49b98da2a72aebcd3
diff --git a/gui-apps/wofi/files/wofi-1.3-no-hg-identify.patch b/gui-apps/wofi/files/wofi-1.3-no-hg-identify.patch
new file mode 100644
index 000000000000..33a4ff63e30b
--- /dev/null
+++ b/gui-apps/wofi/files/wofi-1.3-no-hg-identify.patch
@@ -0,0 +1,31 @@
+commit 455ffaa393267beef7886fa6c32932b65497581f
+Author: John Helmert III <ajak@gentoo.org>
+Date: Tue Dec 13 20:28:27 2022 -0600
+
+ drop hg usage during configure
+
+ Builds aren't run from a mercurial repository, we're always building
+ from a release tarball, and we don't want a dependency on mercurial
+ anyway.
+
+ Signed-off-by: John Helmert III <ajak@gentoo.org>
+
+diff --git a/meson.build b/meson.build
+index e141508..3116a8b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -9,14 +9,8 @@ wayland = dependency('wayland-client')
+ threads = dependency('threads')
+ dl = cc.find_library('dl')
+
+-hg = find_program('hg', native : true, required : false)
+-
+ version = meson.project_version()
+
+-if hg.found()
+- version = run_command(hg, 'identify', check : true).stdout().strip()
+-endif
+-
+ add_project_arguments('-D_GNU_SOURCE', '-DVERSION="' + version + '"', language : 'c')
+ add_project_link_arguments('-rdynamic', language : 'c')
+
diff --git a/gui-apps/wofi/metadata.xml b/gui-apps/wofi/metadata.xml
new file mode 100644
index 000000000000..b5b4be3cdf8b
--- /dev/null
+++ b/gui-apps/wofi/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>John Helmert III</name>
+ <email>ajak@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourcehut">~scoopta/wofi</remote-id>
+ <bugs-to>https://todo.sr.ht/~scoopta/wofi</bugs-to>
+ <doc>https://cloudninja.pw/docs/wofi.html</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wofi/wofi-1.3.ebuild b/gui-apps/wofi/wofi-1.3.ebuild
new file mode 100644
index 000000000000..70187e690c67
--- /dev/null
+++ b/gui-apps/wofi/wofi-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://hg.sr.ht/~scoopta/${PN}"
+else
+ SRC_URI="https://hg.sr.ht/~scoopta/wofi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wofi is a launcher/menu program for wlroots based wayland compositors like sway"
+HOMEPAGE="https://hg.sr.ht/~scoopta/wofi"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-libs/wayland
+ x11-libs/gtk+:3[wayland(-)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3-no-hg-identify.patch" )
diff --git a/gui-apps/wofi/wofi-9999.ebuild b/gui-apps/wofi/wofi-9999.ebuild
new file mode 100644
index 000000000000..70187e690c67
--- /dev/null
+++ b/gui-apps/wofi/wofi-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://hg.sr.ht/~scoopta/${PN}"
+else
+ SRC_URI="https://hg.sr.ht/~scoopta/wofi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wofi is a launcher/menu program for wlroots based wayland compositors like sway"
+HOMEPAGE="https://hg.sr.ht/~scoopta/wofi"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-libs/wayland
+ x11-libs/gtk+:3[wayland(-)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3-no-hg-identify.patch" )