summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-04-20 18:15:02 +0200
committerJohannes Huber <johu@gentoo.org>2017-04-20 18:22:40 +0200
commit8f00b2bf566d896205f52099530159c97b977f68 (patch)
tree6dfeae9f7a9dc7b276cb384a7f4ad8d589de52d1 /kde-apps/ktp-accounts-kcm
parentkde5*eclass: KDE Applications 17.04.0 improvements (diff)
downloadgentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.gz
gentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.bz2
gentoo-8f00b2bf566d896205f52099530159c97b977f68.zip
kde-apps: Version bump KDE Applications 17.04.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.04.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 5f385600aa5a..b159fb5fac66 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1 +1,2 @@
DIST ktp-accounts-kcm-16.12.3.tar.xz 90032 SHA256 0373f4475fa4cedf26595301c571682f1eb56ef0354fb42937e657976248215f SHA512 1dece219675f0a653d34c7b23e44f03bfbafa4cdf3fc8ac383078ea37fef92684bcfd6af91b2d142305ef09f0dc8d233d6332e9dfab69e008ee70d5ffbe3a3f5 WHIRLPOOL c7a6a132bdb6fbb34a6c27f1b79755075456207a224670dc4b8869fc53a25a9038db15a7015699c98817e50d95eb75309e25bf442d6d7f47e9962a579ec29ce2
+DIST ktp-accounts-kcm-17.04.0.tar.xz 263760 SHA256 8c2fe67f127ee04ccdc3955959fc0ee59e0d5e259b4a1d2dddbd4b153dd2082e SHA512 8eecdb56e6add605bd4ae65f8a48c7c43974e8ac7e742226014ce09b8966960097772610ecd7a84568c01f8d0fdf88876ade021887dc1647a167df8442901fc2 WHIRLPOOL 84e04fe02d034cd7dac76e19fb5e773e40f14e0c6885fd4e44abdf7364f4371ff4c793c60be62cac864a61d7ab4e5562e8ca008da736b7eba9d383f96ec6cc24
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.04.0.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.04.0.ebuild
new file mode 100644
index 000000000000..a67ec19116e1
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.04.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+ !kde-apps/ktp-accounts-kcm:4
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}