summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-10-14 20:02:17 +0200
committerSam James <sam@gentoo.org>2022-10-24 14:50:20 +0100
commitb2a9ca8f8c51f74841f098cbadb2cf842297c0a7 (patch)
tree406455882a3064b1cee85d16c97544e5963dc153 /mate-extra
parentmate-extra/caja-actions: new package, add 1.26.0 (diff)
downloadgentoo-b2a9ca8f8c51f74841f098cbadb2cf842297c0a7.tar.gz
gentoo-b2a9ca8f8c51f74841f098cbadb2cf842297c0a7.tar.bz2
gentoo-b2a9ca8f8c51f74841f098cbadb2cf842297c0a7.zip
mate-extra/caja-dropbox: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/caja-dropbox/Manifest1
-rw-r--r--mate-extra/caja-dropbox/caja-dropbox-1.26.0.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/mate-extra/caja-dropbox/Manifest b/mate-extra/caja-dropbox/Manifest
index 28c6ff9a832e..626a4edc58d6 100644
--- a/mate-extra/caja-dropbox/Manifest
+++ b/mate-extra/caja-dropbox/Manifest
@@ -1 +1,2 @@
DIST caja-dropbox-1.24.0.tar.xz 309024 BLAKE2B 2ae560dcd6e744fe96d9e0fcd876a899c22ad06b8238c2ad9e5394cf80aa8844cd634431dc6bb245396e6d919da857645488214880947e5b90413c254cd4c6a2 SHA512 64d699b4c3957d5996ef69936b4b2746641bc2db4efb7b23535febf5eed3ee767330927aeeda67747c0d72e0f052a2979ae2160ffaaf01e4fd82aff68a5f27bf
+DIST caja-dropbox-1.26.0.tar.xz 361352 BLAKE2B 877196d1c6900904314e4ea0f4220821febe123395b1af8eb30e6557beea068ce572621473e733bf41f597a9c72d03ca0b2666cb7c335bbdcaefec06ffd577b9 SHA512 f96e3ddf4434936b04e992044d6cd5797b6ff77ead573e8e9a6493f4308d9716f47871f1fd7f08b0dbf7f2659f107511b6be65e98632a0892ebfff0a9888dbe7
diff --git a/mate-extra/caja-dropbox/caja-dropbox-1.26.0.ebuild b/mate-extra/caja-dropbox/caja-dropbox-1.26.0.ebuild
new file mode 100644
index 000000000000..c32506a04db2
--- /dev/null
+++ b/mate-extra/caja-dropbox/caja-dropbox-1.26.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+MATE_LA_PUNT="yes"
+
+inherit mate python-single-r1 linux-info
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Store, Sync and Share Files Online"
+LICENSE="CC-BY-ND-3.0 GPL-3+ public-domain"
+SLOT="0"
+
+IUSE="debug nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ $(python_gen_cond_dep \
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+ >=mate-base/caja-1.19.1
+ mate-extra/caja-extensions
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libXinerama
+ x11-libs/pango
+"
+
+RDEPEND="${COMMON_DEPEND}
+ net-misc/dropbox
+"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~INOTIFY_USER"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ check_extra_config
+}
+
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Use system dropbox.
+ sed -e "s|~/[.]dropbox-dist|/opt/dropbox|" \
+ -e 's|\(DROPBOXD_PATH = \).*|\1"/opt/dropbox/dropboxd"|' \
+ -i caja-dropbox.in || die
+
+ sed -e 's|\[rst2man\]|\[rst2man\.py\]|' -i configure.ac || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ python_fix_shebang caja-dropbox.in
+
+ mate_src_install
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" "-lt" "1.24.0-r1" || ver_test "${v}" "-eq" "9999"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.24.0-r1, ${PN} now no longer"
+ ewarn "configures caja-dropbox to use its own group. This brings caja-dropbox in line"
+ ewarn "with nautilus-dropbox and dolphin-plugins-dropbox. You may remove the 'dropbox' group."
+ fi
+ done
+}