summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-02-16 08:15:35 +0000
committerSam James <sam@gentoo.org>2025-02-16 08:16:20 +0000
commitf23bdfa87a69f95a61f570c21303794ee1f4dd00 (patch)
tree6aad8bebbe0f2320aca13ac63b51ac2307c0764a /media-sound/alsaplayer
parentx11-misc/xdg-user-dirs-gtk: add 0.14 (diff)
downloadgentoo-f23bdfa87a69f95a61f570c21303794ee1f4dd00.tar.gz
gentoo-f23bdfa87a69f95a61f570c21303794ee1f4dd00.tar.bz2
gentoo-f23bdfa87a69f95a61f570c21303794ee1f4dd00.zip
media-sound/alsaplayer: fix modern C issue, drop LTO filter
* Fix modern C issue in configure (backport from upstream) * Drop LTO filter. It was fixed already upstream, per the comment in the ebuild, in 0.99.82, but the filter wasn't dropped in 68ea65bbb1877f4048d9fec2a598505fa17ae469, so do that now. Bug: https://bugs.gentoo.org/860423 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.82-r1.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.82.ebuild)14
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.82-c99.patch26
2 files changed, 32 insertions, 8 deletions
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.82.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.82-r1.ebuild
index 05d91e5ed653..fd82a83a669d 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.82.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.82-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools desktop flag-o-matic xdg
+inherit autotools desktop xdg
DESCRIPTION="A heavily multi-threaded pluggable audio player"
HOMEPAGE="https://alsaplayer.sourceforge.net/"
@@ -38,7 +38,10 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-text/doxygen )"
-PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-c99.patch
+)
src_prepare() {
default
@@ -47,11 +50,6 @@ src_prepare() {
}
src_configure() {
- # -Werror=odr
- # https://bugs.gentoo.org/860423
- # https://github.com/alsaplayer/alsaplayer/issues/28
- filter-lto
-
export ac_cv_prog_HAVE_DOXYGEN=$(usex doc true false)
export ac_cv_lib_xosd_xosd_create=$(usex xosd)
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.82-c99.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.82-c99.patch
new file mode 100644
index 000000000000..b01a0eba939e
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.82-c99.patch
@@ -0,0 +1,26 @@
+https://github.com/alsaplayer/alsaplayer/commit/65f5db98f58cd5042454c7f834e3698e8cb153e5
+
+From 65f5db98f58cd5042454c7f834e3698e8cb153e5 Mon Sep 17 00:00:00 2001
+From: Adam Sampson <ats@offog.org>
+Date: Tue, 21 Jan 2025 14:15:42 +0000
+Subject: [PATCH] Add missing #include in libmikmod configure test.
+
+GCC 14 treats missing prototypes as an error by default, so this test
+would always fail.
+---
+ m4/libmikmod.m4 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/m4/libmikmod.m4 b/m4/libmikmod.m4
+index e34ab4e0..c33b6f91 100644
+--- a/m4/libmikmod.m4
++++ b/m4/libmikmod.m4
+@@ -64,6 +64,7 @@ dnl
+ #include <mikmod.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ char* my_strdup (char *str)
+ {
+