summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/braa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/braa')
-rw-r--r--net-analyzer/braa/Manifest1
-rw-r--r--net-analyzer/braa/braa-0.82.ebuild25
-rw-r--r--net-analyzer/braa/files/braa-0.8-gentoo.diff24
-rw-r--r--net-analyzer/braa/metadata.xml5
4 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/braa/Manifest b/net-analyzer/braa/Manifest
new file mode 100644
index 000000000000..f8e0f21fcd77
--- /dev/null
+++ b/net-analyzer/braa/Manifest
@@ -0,0 +1 @@
+DIST braa-0.82.tar.gz 39927 SHA256 d650d34cdf30fcbbbbf4e4f11c8f5d51fd5caa3cca58d620fa1d978b8c18919c SHA512 8c88d288287a12c19c8d49606c8d2b70531b7f2be1aa3c4ccc6b01739aead751c03c56dc3f1a346b3dd20730a8bd0d30e33167a5f7c676f629348195762e23d4 WHIRLPOOL 23bd927ee9be8331069865c75389ee6417adec1ffaa4f2c4604cec0f55f786e341249e1bc96948d1e43fb5b6a925aea2e3940a2d8dce3c4060591105efe1c82a
diff --git a/net-analyzer/braa/braa-0.82.ebuild b/net-analyzer/braa/braa-0.82.ebuild
new file mode 100644
index 000000000000..e5a6940cf809
--- /dev/null
+++ b/net-analyzer/braa/braa-0.82.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Quick and dirty mass SNMP scanner"
+HOMEPAGE="http://s-tech.elsat.net.pl/braa/"
+SRC_URI="http://s-tech.elsat.net.pl/braa/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8-gentoo.diff
+ sed -i braa.c -e 's|0.81|0.82|g' || die
+ tc-export CC
+}
+
+src_install() {
+ dobin braa
+ dodoc README
+}
diff --git a/net-analyzer/braa/files/braa-0.8-gentoo.diff b/net-analyzer/braa/files/braa-0.8-gentoo.diff
new file mode 100644
index 000000000000..3167269f4a68
--- /dev/null
+++ b/net-analyzer/braa/files/braa-0.8-gentoo.diff
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,8 +4,6 @@
+ ###################################################################
+
+ # Linux, FreeBSD, OpenBSD
+-CFLAGS =
+-LDFLAGS =
+
+ # Solaris / SPARC
+ # CFLAGS = -DSOLARIS_SPARC
+@@ -24,9 +22,8 @@
+ LIBS =
+
+ all: ${OBJECTS}
+- cc $(OBJECTS) -o $(OUT) $(LDFLAGS) $(LIBS)
+- strip $(OUT)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) -o $(OUT) $(LIBS)
+
+ clean:
+ rm -rf $(OBJECTS) $(OUT)
+-
+\ No newline at end of file
++
diff --git a/net-analyzer/braa/metadata.xml b/net-analyzer/braa/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-analyzer/braa/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>