summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-13 17:33:17 +0100
committerSam James <sam@gentoo.org>2022-08-13 18:22:06 +0100
commit742a294593bd2cee3b6cd4b8096eab7411e7d416 (patch)
tree62211c74f4d59f7a87cd3d8683fc98bb16997b39 /net-fs
parentwww-servers/tomcat: bump to 8.5.82 (diff)
downloadgentoo-742a294593bd2cee3b6cd4b8096eab7411e7d416.tar.gz
gentoo-742a294593bd2cee3b6cd4b8096eab7411e7d416.tar.bz2
gentoo-742a294593bd2cee3b6cd4b8096eab7411e7d416.zip
net-fs/libnfs: add 5.0.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/Manifest1
-rw-r--r--net-fs/libnfs/libnfs-5.0.2.ebuild57
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild5
3 files changed, 61 insertions, 2 deletions
diff --git a/net-fs/libnfs/Manifest b/net-fs/libnfs/Manifest
index 9c633f903ba7..b4273017697e 100644
--- a/net-fs/libnfs/Manifest
+++ b/net-fs/libnfs/Manifest
@@ -1 +1,2 @@
DIST libnfs-5.0.1.tar.gz 279550 BLAKE2B d27e97f3dce1385cabd8076b673d2bbfe339ff5a34295ca13bfea2f9c2048f4c6dd07a0b54b7cc7e44aecda58dd21520732dc6ee82260f0694a01fec59875a6a SHA512 71f2dcfa8945c1cb6402f5fca10b1f7a4720f7589807d6130eb55361f05ef4684f9cc9a177ece4e13d3847ac6606924115fac7b27749cecc2f5aca6fa9c63ebf
+DIST libnfs-5.0.2.tar.gz 281154 BLAKE2B 9de3d02e5ae4d41eacda152678e6552708b33d4e88cc6fc5f7b16c887f911fc5a5e834952505438220c961f71a8b70540be3254d5889a4336200d5633dce313e SHA512 6dcf4ea8a01b35beb53694625d20fbebd858a88725c2742671878ad6fe7877999f93d262fb58a435b00c283c3e6fb6fa7222d04bb4540bf674b7ce196e9424f5
diff --git a/net-fs/libnfs/libnfs-5.0.2.ebuild b/net-fs/libnfs/libnfs-5.0.2.ebuild
new file mode 100644
index 000000000000..3fedbd9d1bc3
--- /dev/null
+++ b/net-fs/libnfs/libnfs-5.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/14" # sub-slot matches SONAME major
+IUSE="examples static-libs utils"
+
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="net-libs/rpcsvc-proto
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable utils)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index c586e1123012..3fedbd9d1bc3 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
+
if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
- EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"