summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/minbif
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/minbif')
-rw-r--r--net-im/minbif/Manifest1
-rw-r--r--net-im/minbif/files/minbif-1.0.5-gcc47.patch76
-rw-r--r--net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch26
-rw-r--r--net-im/minbif/files/minbif.initd24
-rw-r--r--net-im/minbif/metadata.xml8
-rw-r--r--net-im/minbif/minbif-1.0.5-r1.ebuild84
6 files changed, 219 insertions, 0 deletions
diff --git a/net-im/minbif/Manifest b/net-im/minbif/Manifest
new file mode 100644
index 000000000000..9fd56fb32d49
--- /dev/null
+++ b/net-im/minbif/Manifest
@@ -0,0 +1 @@
+DIST minbif-1.0.5.tar.gz 176039 SHA256 88271af203a89556165a9ebb4e00e55ea5b649146aea855dd799a79bd9e4befd SHA512 e84c6f38ad35a660f9c319b702ae5743cece167c8e116976a9ca0caf527ad23ea17ea8f518f9bd76536e87283362d2087201a5307128740fc7f05dccabacfbcd WHIRLPOOL 10e51abc809e16c65c86f5887867f9d4b680a60321921a2fdd58345ce100cdea8317d13a007df4efaae786a4ea1b1bdc0231fe186f877f6a5716dbfdc3c32aad
diff --git a/net-im/minbif/files/minbif-1.0.5-gcc47.patch b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
new file mode 100644
index 000000000000..8566406a318f
--- /dev/null
+++ b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
@@ -0,0 +1,76 @@
+commit fe71fd989a4501c77314b2906756f4e9a328ff31
+Author: Romain Bignon <romain@symlink.me>
+Date: Tue May 8 16:46:35 2012 +0200
+
+ fixes for gcc 4.7
+
+--- a/src/im/account.cpp
++++ b/src/im/account.cpp
+@@ -18,6 +18,7 @@
+
+ #include <cassert>
+ #include <cstring>
++#include <unistd.h>
+ #ifdef HAVE_IMLIB
+ #include <Imlib2.h>
+ #endif /* HAVE_IMLIB */
+--- a/src/im/request.cpp
++++ b/src/im/request.cpp
+@@ -18,6 +18,7 @@
+
+ #include <errno.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #include "request.h"
+ #include "buddy.h"
+--- a/src/irc/dcc.cpp
++++ b/src/irc/dcc.cpp
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <unistd.h>
+
+ #include "dcc.h"
+ #include "nick.h"
+--- a/src/irc/irc.cpp
++++ b/src/irc/irc.cpp
+@@ -246,7 +246,7 @@ Nick* IRC::getNick(string nickname, bool case_sensitive) const
+ Buddy* IRC::getNick(const im::Buddy& buddy) const
+ {
+ map<string, Nick*>::const_iterator it;
+- Buddy* nb;
++ Buddy* nb = NULL;
+ for(it = users.begin();
+ it != users.end() && (!(nb = dynamic_cast<Buddy*>(it->second)) || nb->getBuddy() != buddy);
+ ++it)
+@@ -261,7 +261,7 @@ Buddy* IRC::getNick(const im::Buddy& buddy) const
+ ConvNick* IRC::getNick(const im::Conversation& conv) const
+ {
+ map<string, Nick*>::const_iterator it;
+- ConvNick* n;
++ ConvNick* n = NULL;
+ for(it = users.begin();
+ it != users.end() && (!(n = dynamic_cast<ConvNick*>(it->second)) || n->getConversation() != conv);
+ ++it)
+--- a/src/server_poll/inetd.cpp
++++ b/src/server_poll/inetd.cpp
+@@ -18,6 +18,7 @@
+
+ #include <cassert>
+ #include <glib.h>
++#include <unistd.h>
+
+ #include "inetd.h"
+ #include "irc/irc.h"
+--- a/src/sockwrap/sockwrap.cpp
++++ b/src/sockwrap/sockwrap.cpp
+@@ -22,6 +22,7 @@
+ # include "sockwrap_tls.h"
+ #endif
+ #include "core/util.h"
++#include <unistd.h>
+
+ namespace sock
+ {
diff --git a/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch b/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch
new file mode 100644
index 000000000000..599355eb502c
--- /dev/null
+++ b/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch
@@ -0,0 +1,26 @@
+Index: minbif-1.0.5/src/server_poll/daemon_fork.cpp
+===================================================================
+--- minbif-1.0.5.orig/src/server_poll/daemon_fork.cpp
++++ minbif-1.0.5/src/server_poll/daemon_fork.cpp
+@@ -20,7 +20,7 @@
+ #include <cassert>
+ #include <cstring>
+ #include <cerrno>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <arpa/inet.h>
+Index: minbif-1.0.5/src/server_poll/inetd.cpp
+===================================================================
+--- minbif-1.0.5.orig/src/server_poll/inetd.cpp
++++ minbif-1.0.5/src/server_poll/inetd.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include <cassert>
+-#include <glib/gmain.h>
++#include <glib.h>
+
+ #include "inetd.h"
+ #include "irc/irc.h"
diff --git a/net-im/minbif/files/minbif.initd b/net-im/minbif/files/minbif.initd
new file mode 100644
index 000000000000..a2d5649bfe1f
--- /dev/null
+++ b/net-im/minbif/files/minbif.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MINBIF_EXEC="/usr/bin/minbif"
+
+depend() {
+ need logger net
+}
+
+start() {
+ ebegin "Starting minbif"
+ start-stop-daemon --start --startas ${MINBIF_EXEC} \
+ -c minbif:minbif --exec ${MINBIF_EXEC} -- \
+ /etc/minbif/minbif.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping minbif"
+ start-stop-daemon --stop --exec ${MINBIF_EXEC}
+ eend $?
+}
diff --git a/net-im/minbif/metadata.xml b/net-im/minbif/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/net-im/minbif/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-im/minbif/minbif-1.0.5-r1.ebuild b/net-im/minbif/minbif-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..1586a3d525be
--- /dev/null
+++ b/net-im/minbif/minbif-1.0.5-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils user
+
+DESCRIPTION="an IRC gateway to IM networks"
+HOMEPAGE="https://symlink.me/projects/minbif/wiki/"
+SRC_URI="https://symlink.me/attachments/download/148/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="gnutls +imlib +libcaca pam xinetd"
+REQUIRED_USE="
+ libcaca? ( imlib )
+"
+
+DEPEND="
+ >=net-im/pidgin-2.6
+ libcaca? ( media-libs/libcaca media-libs/imlib2 )
+ imlib? ( media-libs/imlib2 )
+ pam? ( sys-libs/pam )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}
+ virtual/logger
+ xinetd? ( sys-apps/xinetd )
+"
+
+pkg_setup() {
+ enewgroup minbif
+ enewuser minbif -1 -1 /var/lib/minbif minbif
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.5-glib-single-includes.patch"
+ epatch "${FILESDIR}/${PN}-1.0.5-gcc47.patch"
+
+ sed -i "s/-Werror//g" CMakeLists.txt || die "sed failed"
+
+ sed -i "s#share/doc/minbif#share/doc/${P}#" \
+ CMakeLists.txt || die "sed failed"
+
+ if use xinetd; then
+ sed -i "s/type\s=\s[0-9]/type = 0/" \
+ minbif.conf || die "sed failed"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs="${mycmakeargs}
+ -DCONF_PREFIX=${PREFIX:-/etc/minbif}
+ -DENABLE_VIDEO=OFF
+ $(cmake-utils_use_enable libcaca CACA)
+ $(cmake-utils_use_enable imlib IMLIB)
+ $(cmake-utils_use_enable pam PAM)
+ $(cmake-utils_use_enable gnutls TLS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ keepdir /var/lib/minbif
+ fperms 700 /var/lib/minbif
+ fowners minbif:minbif /var/lib/minbif
+
+ dodoc ChangeLog README
+ doman man/minbif.8
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins doc/minbif.xinetd minbif
+ fi
+
+ newinitd "${FILESDIR}"/minbif.initd minbif
+
+ dodir /usr/share/minbif
+ insinto /usr/share/minbif
+ doins -r scripts
+}