summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2023-02-25 20:39:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-26 04:59:49 +0100
commit65b3c5533c7f0225e74427f3f2d3589ff29136c4 (patch)
tree900f2157437ecfbb50ffe37e988fbe908a235b48 /net-wireless
parentdev-python/doit: Use pypi.eclass (diff)
downloadgentoo-65b3c5533c7f0225e74427f3f2d3589ff29136c4.tar.gz
gentoo-65b3c5533c7f0225e74427f3f2d3589ff29136c4.tar.bz2
gentoo-65b3c5533c7f0225e74427f3f2d3589ff29136c4.zip
net-wireless/blueberry: version bump to 1.4.8
Update to latest upstream version Add python 3.11 support Closes: https://bugs.gentoo.org/897162 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.4.8.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index 854be1728113..f098c1eb5333 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.4.7.tar.gz 1415642 BLAKE2B 59b419d73416105d3d853cc8c5f6cba3f1171f441478ec7f3bdfaaeea22ce07afef3da372a1f993345a7fb38621d0d163ebb4a4d9e8b9e919d71af47e79dfb98 SHA512 2562017da0a102d5fde2905aa4d76cbcd761eeb5e17b137bb6a0bd22d518dfb677bb6ce1e05eb109a1b8ae35588f56f0d42b56f455aaec174155614966551eee
+DIST blueberry-1.4.8.tar.gz 1416910 BLAKE2B ef122021709443fa7a06e6759450ca8b3bc2c21ee930b0bc532454001addb49df1320a177f8b2e217b59e4a931f1634eea642c1d625ba255ecffff573d60cc34 SHA512 32dbc4fa91321eb1401afa4ac4cc42794ef8cac9ed63ad19c3fd34d88e0eb6c7aa51d3aa3a2f8017a9f6135ab16ca154a929ce5ff592f5157bb3f799a9ef8891
diff --git a/net-wireless/blueberry/blueberry-1.4.8.ebuild b/net-wireless/blueberry/blueberry-1.4.8.ebuild
new file mode 100644
index 000000000000..e9cf5cf3b9b0
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.4.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/python3-xapp[${PYTHON_USEDEP}]
+ ')
+ >=net-wireless/gnome-bluetooth-3.14:2[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang usr/lib
+}
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}