diff options
author | Alexey Sokolov <sokolov@google.com> | 2020-10-10 11:16:19 +0100 |
---|---|---|
committer | Joonas Niilola <juippis@gentoo.org> | 2020-10-10 14:46:01 +0300 |
commit | 36feeb097ad8a44604ff04cda47fad12169139d9 (patch) | |
tree | 7b4512ad09c46e3fcf16c6848fb788260f875ff4 /sci-astronomy | |
parent | sys-auth/sssd: Drop old (Security cleanup) (diff) | |
download | gentoo-36feeb097ad8a44604ff04cda47fad12169139d9.tar.gz gentoo-36feeb097ad8a44604ff04cda47fad12169139d9.tar.bz2 gentoo-36feeb097ad8a44604ff04cda47fad12169139d9.zip |
sci-astronomy/stellarium: fix patches
Somehow CRLF line endings were lost. Some files have CRLF line endings,
and some have LF only.
Bug: https://bugs.gentoo.org/745234
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-astronomy')
3 files changed, 44 insertions, 44 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch index ac3f84d5bb66..33d355f842f4 100644 --- a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch +++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-indi.patch @@ -72,11 +72,11 @@ index 6fcf7678da..a59d8c121c 100644 --- a/src/external/CMakeLists.txt +++ b/src/external/CMakeLists.txt @@ -176,7 +176,7 @@ target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel) - set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external") - - ################################# INDI ################################ --IF(USE_PLUGIN_TELESCOPECONTROL) -+IF(USE_PLUGIN_TELESCOPECONTROL AND 0) - set(INDI_SOVERSION "1") - set(CMAKE_INDI_VERSION_MAJOR 1) - set(CMAKE_INDI_VERSION_MINOR 6) + set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
+
+ ################################# INDI ################################
+-IF(USE_PLUGIN_TELESCOPECONTROL)
++IF(USE_PLUGIN_TELESCOPECONTROL AND 0)
+ set(INDI_SOVERSION "1")
+ set(CMAKE_INDI_VERSION_MAJOR 1)
+ set(CMAKE_INDI_VERSION_MINOR 6)
diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch index 7a585b71894b..64b19a54c88a 100644 --- a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch +++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-qtcompress.patch @@ -93,30 +93,30 @@ index 1e0e7e2b32..834aff89cb 100644 --- a/src/external/CMakeLists.txt +++ b/src/external/CMakeLists.txt @@ -70,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib) - set_target_properties(zlib_stel PROPERTIES AUTOMOC 0) - SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external") - -+if(0) - set(qtcompress_SRCS - qtcompress/qzip.cpp - qtcompress/qzipreader.h + set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ set(qtcompress_SRCS
+ qtcompress/qzip.cpp
+ qtcompress/qzipreader.h
@@ -82,6 +83,7 @@ target_link_libraries(qtcompress_stel ${ZLIB_LIBRARIES} Qt5::Core) - #turn off automoc, not needed here - set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0) - SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external") -+endif() - - set(qcustomplot_SRCS - qcustomplot/qcustomplot.cpp + #turn off automoc, not needed here
+ set_target_properties(qtcompress_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(qtcompress_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ set(qcustomplot_SRCS
+ qcustomplot/qcustomplot.cpp
@@ -176,7 +176,7 @@ - qxlsx/xlsxcelllocation.h - ) - add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS}) --target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel) -+target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress) - set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external") - - ################################# INDI ################################ + qxlsx/xlsxcelllocation.h
+ )
+ add_library(qxlsx_stel STATIC EXCLUDE_FROM_ALL ${qxlsx_SRCS})
+-target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui qtcompress_stel)
++target_link_libraries(qxlsx_stel Qt5::Core Qt5::Gui Qt5::Compress)
+ set_target_properties(qxlsx_stel PROPERTIES FOLDER "src/external")
+
+ ################################# INDI ################################
diff -r 11536448457a xlsxzipreader.cpp --- a/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:41:22 2020 +0100 +++ b/src/external/qxlsx/xlsxzipreader.cpp Thu Oct 08 21:42:03 2020 +0100 diff --git a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch index 37acb83e667e..6fb7fb4f7859 100644 --- a/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch +++ b/sci-astronomy/stellarium/files/stellarium-0.20.3-unbundle-zlib.patch @@ -6,18 +6,18 @@ index 834aff89cb..590579e501 100644 --- a/src/external/CMakeLists.txt +++ b/src/external/CMakeLists.txt @@ -36,6 +36,7 @@ target_link_libraries(glues_stel Qt5::Gui) - set_target_properties(glues_stel PROPERTIES AUTOMOC 0) - SET_TARGET_PROPERTIES(glues_stel PROPERTIES FOLDER "src/external") - -+if(0) - SET(zlib_SRCS - zlib/adler32.c - zlib/compress.c + set_target_properties(glues_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(glues_stel PROPERTIES FOLDER "src/external")
+
++if(0)
+ SET(zlib_SRCS
+ zlib/adler32.c
+ zlib/compress.c
@@ -69,6 +70,7 @@ target_include_directories(zlib_stel PUBLIC zlib) - #turn off automoc, not needed here - set_target_properties(zlib_stel PROPERTIES AUTOMOC 0) - SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external") -+endif() - - if(0) - set(qtcompress_SRCS + #turn off automoc, not needed here
+ set_target_properties(zlib_stel PROPERTIES AUTOMOC 0)
+ SET_TARGET_PROPERTIES(zlib_stel PROPERTIES FOLDER "src/external")
++endif()
+
+ if(0)
+ set(qtcompress_SRCS
|