summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-02 04:19:37 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-02 04:19:37 +0100
commit79838b33f1601376b91619946571004aa16be3a1 (patch)
tree26a9e83c3d0f6e30f207da8c535a70e33afa0df3 /sci-biology
parentsci-biology/bamtools: Version bump to 2.4.2 (diff)
downloadgentoo-79838b33f1601376b91619946571004aa16be3a1.tar.gz
gentoo-79838b33f1601376b91619946571004aa16be3a1.tar.bz2
gentoo-79838b33f1601376b91619946571004aa16be3a1.zip
sci-biology/bamtools: Add live ebuild
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bamtools/bamtools-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-biology/bamtools/bamtools-9999.ebuild b/sci-biology/bamtools/bamtools-9999.ebuild
new file mode 100644
index 000000000000..e6daa8262028
--- /dev/null
+++ b/sci-biology/bamtools/bamtools-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
+HOMEPAGE="https://github.com/pezmaster31/bamtools"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pezmaster31/bamtools.git"
+else
+ SRC_URI="https://github.com/pezmaster31/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}" # no stable ABI yet
+
+RDEPEND="
+ >=dev-libs/jsoncpp-1.8.0:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+mycmakeargs=( -DBUILD_SHARED_LIBS=ON )