summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-08-23 17:51:04 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-08-23 17:51:04 -0600
commit7cbbf1df31c9ba400f57a3888988781f31b7ce6d (patch)
treece9c9d66913040bcc36a2fdc23716edc3ff9fa20 /sci-chemistry
parentapp-laptop/tpacpi-bat: fixed live ebuild (diff)
downloadgentoo-7cbbf1df31c9ba400f57a3888988781f31b7ce6d.tar.gz
gentoo-7cbbf1df31c9ba400f57a3888988781f31b7ce6d.tar.bz2
gentoo-7cbbf1df31c9ba400f57a3888988781f31b7ce6d.zip
sci-chemistry/gromacs: fix sandbox issue (bug #591952)
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/gromacs-2016.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2016.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2016.9999.ebuild b/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
index 1b02d2ad989c..b09b2477a31e 100644
--- a/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2016.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs
+inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs xdg-utils
if [[ $PV = *9999* ]]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs.git
@@ -93,6 +93,8 @@ src_prepare() {
#notes/todos
# -on apple: there is framework support
+ xdg_environment_reset #591952
+
cmake-utils_src_prepare
use cuda && cuda_src_prepare
diff --git a/sci-chemistry/gromacs/gromacs-2016.ebuild b/sci-chemistry/gromacs/gromacs-2016.ebuild
index 1ca034301050..c93c50724cc6 100644
--- a/sci-chemistry/gromacs/gromacs-2016.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2016.ebuild
@@ -6,7 +6,7 @@ EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs
+inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs xdg-utils
if [[ $PV = *9999* ]]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs.git
@@ -93,6 +93,8 @@ src_prepare() {
#notes/todos
# -on apple: there is framework support
+ xdg_environment_reset #591952
+
cmake-utils_src_prepare
use cuda && cuda_src_prepare
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 5493e601ed40..4a21c979f07e 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs
+inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs xdg-utils
if [[ $PV = *9999* ]]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs.git
@@ -93,6 +93,8 @@ src_prepare() {
#notes/todos
# -on apple: there is framework support
+ xdg_environment_reset #591952
+
cmake-utils_src_prepare
use cuda && cuda_src_prepare